Advanced Materials

From TOI-Pedia

Snow Scene Background.jpg

Introduction

Revit is first and foremost a modeling tool not so much a visualization tool. It's primary focus is integrating the different aspects of multidisciplinary design. Because visualization is not its primary purpose and only part of the functionality of Revit, it is Limited. However this doesn't mean Revit ins't capable of producing high quality images.

Revit uses a physically-based rendering engine (PBR). This means that it will simulate the real world physical properties of materials.

Since Revit 2019 there are new physically-based material assets available. These assets allow for more accurate light reflection and diffusion. Older material assets can be used alongside the newer ones, or you can replace older assets with the new PBR assets. These newer assets also have the possibility of adding height or normal maps, where previsouly only bump maps were used.

Creating a PBR material asset or adjusting an existing one is easier than before. Moreover you have more control over your assets because you have more settings.

Snow Scene Background Explained 1.png

The above image is made entirely with Revit and cloud rendering. There is no post production or editing involved, everything is done inside Revit. It is a combination of different tools available, which will be explained here. (the lighting is not correct in this particular image it is just to show the use of a background image)

Material Basics

In this section we will cover the basics of creating a material, this is not limited to Revit. Many of the things discussed here are used in other render engines, for example: Blender, Vray, Arnold, etc. A Material is comprised of a collection of maps (images) and values that represent different properties. To add detail and complexity to a material different techniques are used to emulate physical properties of real world materials. Note that not all maps are needed to create a material, some maps reflect different workflows but most programs still offer all the possible ways of creating and defining material properties.

Color

The basis of every material is a color,texture or image (photo). Also called a diffuse, color or albedo. Although the terminology is sometimes mixed there is a difference between them.


Color

A color map is solid color.

Color Map Red.JPG
Material (Color map)


Albedo

An albedo map is an image or texture without any shadows or highlights (unlit).

Brick Albedo.jpeg
Material (Albedo)


Diffuse

A diffuse map is an image or texture.

Brick Diffuse.jpeg
Material (Diffuse)

Depth/Shading

To create the illusion of depth or surface details we can use different images that are sometimes used alongside each other.

  • Bump map
  • Height map
  • Normal map
  • Displacement map
  • Ambient Occlusion
  • Cavity map

In Revit however we are limited and we can only use a height or normal map.


Height

A Height map is a grey-scale image with 3D height information. Pure white represents the highest part of the model and pure black represents the lowest point of the model. It shifts parts of the visible texture around from the angle of the camera so that protruding parts can occlude parts of the surface, thus suggesting height differences.

Brick Height.jpeg
Material (Height & Albedo)


Normal

A normal map is way of converting the details of a high quality 3D model onto a low poly model or flat surface. It stores the normals of a 3d surface in a 2d image. With different colors representing different directions. Normal maps effect the lighting of a surface.

Color Map
Material (Normal & Albedo)


Ambient Occlusion

Ambient occlusion cannot be used in Revit directly, but we can use it as a multiply layer in Photoshop and export as our new diffuse. This way occluded areas will appear darker. Together with our height/normal map the joints between the bricks become more defined. (If there is a seperate channel for ambient occlusion you should use it)

Color Map
Ambient Occlusion (Height & Albedo)

Lighting/Reflection

  • Roughness map
  • Glossiness map
  • Reflection map
  • Specular



Roughness

A roughness map is a grey-scale image that represent rough and smooth areas of a material. In this case black represents the smooth area and white the rough area. It actually describes the surface irregularities and the accompanying reflection of light. Rough surfaces will reflect the same amount of light as smooth surfaces but the reflection will be blurred and more diffuse.

Color Map
Roughness (Ambient Occlusion & Height & Albedo)


Reflection
A reflection map is an image that is reflected on the surface of our material. For this to work the material has to be shiny and smooth. Use a reflectivity map if you want a scene reflected on a surface, in this case fingerprints. Note that this is not the correct way to add fingerprints to a material, these effects should be mixed in with the roughness map.

Color Map
Reflected Fingerprints


Specular
A specular map is an image where the intensity of the pixels and the color is used to produce the highlights of a material. In this example the white fibers of a Carbon-Fiber material. This material has a black base color and a transparent top-coat.

Color Map
Specular Highlights

Special

Anisotropy map
An anisotropy map controls the shape of highlights on a surface. It deforms the shape of the reflection. In this case brushed metal. If you have ever looked at the bottom of a pan you will see the highlights fanning out from the center. Anisotropy and roughness effect each other so if it is not required for a specific look I would not use this.

Color Map
Brushed Metal



Cutout map
A cutout map determines, with black and white, what parts are visible and what parts are removed. Black is removed and white is visible. You can use this for surfaces that have almost no thickness like fences. If a cutout material is applied to a wall it will not work like an extrusion of your applied material, it will only cut the surface and will not have a solid part. In that case you can use voids to cut solids.

Color Map
Cutout Material


Emissivity

Color Map
Emissive Material

Creating/Editing Revit Material Asset

This section is specific for Revit Materials


Acessing PBR Assets

  • Navigate to: Manage tab>Materials.
  • Click on the show hide library button in the material browser to see the new material assets.

Material Browser Library.jpeg

  • Search for a asset and click the small arrow icon, which appears when hovering over the material, to load it in your project.

Material Browser Library Asset.jpeg

  • Right click the material, duplicate and rename

Duplicate Material.jpeg

  • Click on the new material and duplicate the asset, above the hand icon there should be a 0, indicating no other materials use that asset. In the information tab the asset can be renamed.

Duplicate Asset.jpeg

  • Now the asset can be edited in a non destructive way, the original material will not be changed. If the material or the asset is not duplicated, objects that use the original materials will also change.



Note that assets from 2018 and earlier have a yellow exclamation mark if Revit 2019 is installed. These do not use the PBR-workflow and are not covered here.


Asset Category

Revit has four basic category's for its 2019 PBR materials. Each one has similar options, but they differ in some which cannot be edited. Choosing the right category for your material is crucial. The four category's Revit offers are:

  • Metal
  • Non-Metal
  • Transparant
  • Base & Top-Coat


Metal

Metal has a fixed amount of reflectance (100%) which cannot be edited. What this means is that with a roughness value of 0 it acts as a perfect mirror.

Metal.jpeg
Metal Material


Non Metal

A Non-Metal has a reflectance value of 0.00-0.08 (0-8%). For most materials a value of 0.04 (4%) is sufficient.

Non-Metal.jpeg
Non-Metal Material


Transparent

Transparent materials have an absorption distance and an index of refraction instead of reflectance (IOR). IOR has a fixed value for different materials and determines how much the path of light is refracted or bent when passing through a material. The absorption distance is the distance light has to travel to reach the selected base color of the transparent material. If the thickness of the material stays the same a shorter absorption distance will result in a darker color, beyond that the color will not change. If the absorption distance is longer than the thickness of the object the base color will not be reached.

Glass.jpeg
Transparent Material


Base & Top-Coat

Special materials have a base color with highlights and a top coat with a reflectance of 0.00-1.00 (0-100%). In this case the carbon fiber material has a base color which is black and highlights (specular) which represent the strands or fibers. It has its own roughness and the weight determines the visibility of the specular highlights. The normal map is a standard plain weave. Anisotropy is used so that there is also a checkered effect of the weave pattern in this case a plain weave which corresponds with the specular map. The top coat has its own reflectance (0-1, 0-100%) and roughness. When the reflectance of the top coat is 100% you will not see the base coat anymore because the top coat acts as a perfect mirror. (note that some of the maps have been scaled up to make the effects more visible)

Base Top-Coat.jpeg
Carbon-Fiber Material


Required Maps

A simple Revit material asset consists of one of the four basic category's and three values/images. For our example Brick this would be:

  • Non-Metal
  • Color/Diffuse/Albedo
  • Roughness map
  • Normal/Height map
Albedo Roughness Height.jpegBrick Material Browser.jpeg
Non-Metal, Albedo & Roughness & Height


Choice of category, associated parameters and maps

  • Category

The choice of material category should be relatively simple it's either a metal or not a metal. Both cannot be transparent and then there is the last category base & top coat which should only be chosen if you try to recreate a material which consists of distinct layers.

  • Roughness map

The roughness map defines the surface of your material, this can be done using a slider, in which everything will have the same roughness. 0 is smooth and 1 is rough, this translates to black=0 and white=1. So a completely white image in the roughness input will result in a completely smooth surface, depending on the category this could be a mirror (metal).

  • Normal/Height map

The choice between a normal or a height map depends of the amount and scale of detail. Consider what is more important: the overall height difference of the material or smaller less protruding details. So if the overall silhouette is more important than intricate details use a height map in all other cases use a normal map. A normal map also has a depth amount slider, this defines the total height difference and should be used to tweak the look of the material.

  • Anisotropy

Should only be used to simulate certain specific effects. Otherwise it might effect your roughness/reflectance in an unwanted way. If roughness is 1 (white) and anisotropy is between 0.01-1 (1%-100%) your material will not reflect light in a completely diffuse way. The color input should be white, unless certain parts have to stand out more than other parts, an image (specular) can be used to make certain parts appear darker or lighter.

Editing existing PBR material


  • The new material assets are not pre-loaded into a new project so to Edit existing PBR materials go to the material browser. Click on the library button to see all the material assets available.

Revit Access Library.png

  • Search for the material you want to edit for example: Brick. Click on the arrow icon when hovering over the material to load it into your current project.

Load Brick.png

  • Right click the material and select duplicate. Right click the new (material name)(1) and give it a recognizable name.

Duplicate material.png

  • Next go to the appearance tab and select duplicate asset. The hand icon in the top left of the appearance tab should say 0. You can change the name of the asset in the properties>information>name. Now the asset can be edited.

Duplicate Asset 2.png<

  • Click on the file location under the properties>parameters>image.

File Location Brick.png

  • From here you can just right-click the image and copy to your own project folder to edit with Photoshop or other software.

Copy Brick Albedo.png

  • After editing click the file location under the properties>parameters>image and select your edited image.

Edited PBR material.png

Decals

Decals are images that can be placed on Floors/Walls/Roofs. The most obvious use of these is to create and include signs, art, computer screen or other imagery in your project. You can also use it to add layers of complexity to your materials. This is easier than mixing it in with your diffuse/albedo map. This way we can add dirt/snow or even plants to our walls or floors. It also works well for materials which have unique visual characteristics like corten-steel for example, where patterns of rust will be repeated and clearly seen. So this effect can be broken up by using decals or to add detail in certain places.


NoDecal applied.PNGDecal applied.PNG


A decal consist of three maps. Of which one is required.

  • Image/texture

Ivy.jpg

Optionally

  • Cutout map

Ivy alpha.jpg

  • Bump map

Ivy bump.jpg

Creating a decal

  • Go to insert>decal types

Decal Types.png

  • Click on create new decal in the bottom left and rename.

Create Decal.png

  • Click on the button next to the Source setting and select your image/texture.

Select Source.png

  • Select image in the Cutouts setting and select your cutout map as the source. (the same applies to the bump map)

Decal Image Cutout.png

  • Click OK to close the decal types window and go to insert>place decal and click on the wall/floor to apply the decal.

Place decall wall.png

  • The decal can now be copied/moved/scaled

Resize scale move decal.png


Imported Objects

When importing 3D objects from other software into revit, applying materials can be a bit of a challenge. If the imported objects are square and orthographic there is no problem applying materials. When surfaces are at an angle other than 90 degrees, or the objects are not square it gets a bit tricky. Revit does not have the option to specify a UV layout of an object or surface. UV mapping is the process of unwrapping a 3D object so that a flat texture can be applied to a 3D object. If you have a sphere in revit and apply a material to it, it will project the texture from a flat surface onto the sphere, this means the sides the texture will be warped. Below are a few examples. The only way to overcome this is by applying a solid color to the object or making a specific instance of the material that matches the surface.


UV mapping Revit.png


In the image below you can see the effect on the tree if you look closely at the branches. The bark texture is stretched across, but because the object is not in the foreground it is fine.
Imported Tree.jpeg


Creating Entourage Family

In this case we have an .obj file of a tree. The way to do this is generally the same for all imported objects.

  • Open the .obj in rhino and create layers for all the different elements (this way you can materialize in Revit later, otherwise all imported objects will have layer 0 and will all change material at once,)
  • Export as a .dxf
  • Create a new family go to File>New>Family

File new family.jpeg

  • Select a "Metric Entourage" Family template
  • Go to Insert>Import CadImport Cad.jpeg
  • Import units in this case mm (depends on Rhino file)
  • Select the object and go to Properties Panel>Visibility and Graphics>Edit

Visibility.jpeg

  • Uncheck all except "Fine", and draw something that represents a tree and make sure those are visible only on coarse and medium. This way you can add detailed objects without slowing down the model too much. (if you want to see the object in plan views and elevations you can check them)

Visibility Edit.jpeg

  • Save the family and load into the project
  • Go to Manage>Object StylesObject Styles.jpeg
  • Go to imported Objects and you should see the layers you created in Revit

Object styles imported objects.jpeg

Artificial Lighting

There are some standard lighting family's available within Revit. You can use these and edit them to fit your project or you can create your own. The lighting family's available are limited however.

  • To see all the artificial lights in your scene go to view>render>lighting>artificial lights.
  • Dimming 0 means off, 1 means on.

Creating Lighting Family

Any family template can be a lighting fixture. The only difference is that you have to add a light source to a non lighting fixture family template.

  • Create a new family go to File>New>Family

File new family.jpeg

  • Select a "Metric Generic Model Face Based" Family template
  • go to Create>Family category and Parameters Family category parameters.jpeg, scroll down to "Lighting fixture", Check "Cut with Voids When Loaded" and "Light Source"

Family category lighting.jpeg

  • You will now see a yellow outline of a light source
  • Click on the yellow outline, go to Modify>Light Source DefinitionLight source definition.jpeg
  • In this case "Emit from shape = Point" and "Light Distribution = Spot ", and click apply

Light source defined.jpeg
(the other shapes are self explanatory, "Light Distribution" however has one option called Photometric web. This can be supplied by a manufacturer of lighting fixtures and describes the light intensity distribution of a light source, do not use this unless you know what you are doing)

  • Our yellow outline has now changed to a spotlight
  • Mirror the light source in a side view, this way it will shine light away from the geometry it is hosted on
  • Create a void extrusion (select void extrusion Modify>Cut and select the placeholder geometry), this way the family will cut any host it is attached to.
  • Create some geometry for the lighting fixture (In this case a simple can will do), make sure there is no geometry obstructing the light source definition

Face based lighting fixture.jpeg

  • Go to Modify>Family Types Family types.jpeg (or type propertiesType properties.jpeg after importing to the main model) to edit the Photometrics

Family types photometrics.jpeg

  • Here you can change the color and intensity of the light source, leave light loss factor at 1 (unless you know what you are doing),
  • Now import the model into your project and place it on any surface.

Face Based Lighting.jpeg

  • You will not see where the light is coming from, it will only illuminate part of your model (If you want you can add geometry just underneath the light source and add a material with illuminance)

Render settings

There are two ways to render a scene in Revit: Local and cloud rendering. As a student you have unlimited credits so you can render as much as you want. You are however limited to 16 credits per request to render. So if you want all your views rendered in high quality you have to send them one by one.

Local/Cloud settings

  • Go to view>render to open up the rendering settingsRender Button.jpeg
  • The settings here affect local rendering and only "lighting" and "Background" affect cloud rendering as well.
  • When you select a different lighting scheme you can see your artificial lights.
  • When selecting the scheme "sun and artificial lighting", note that lights may not be on, only during a specific time in the morning and evening.
  • You can add your own background image in Revit, but you have more control and it is easier to do this in an image editing software.
Rendering dialog box.jpeg

Cloud Settings

  • Go to view>Render in CloudRender Cloud Button.jpeg
  • Select your 3D view
  • Output type = Still Image
  • Render Quality = Final
  • Image size = Maximum (16 Mega Pixel)
  • Exposure = Native
  • File Format = PNG (JPEG or TIFF can also be used)
  • You can select Alpha if you want no background or to add your own background image in photoshop.
  • This will cost 16 credits, the maximum per request, so you have to repeat this for each view if you want the highest quality.
Rendering Cloud.jpeg

Render Tips

  • As a student you have unlimited credits (16 per request), so make use of them.
  • When test rendering you can send the same view multiple times, it will be rendered as a separate view each time in your gallery.
  • You can edit the exposure values after rendering inside the Gallery.
  • Use cloud rendering so you can continue working on your model.
  • Use Render region and Best Quality if you want to quickly see how a material looks.
  • Materials can look different when rendering in draft or high quality.
Personal tools
Actions
Navigation
Tools