AutoCAD Page setup and Printing Basic

From TOI-Pedia


This tutorial covers how to make a basic page setup in AutoCAD in order to print your drawing(s).

Printing in AutoCAD is (historically) called plotting.

This tutorial assumes that you're drawing is set up in millimeters (in model space, 1 unit represents 1 mm). Please make sure you're drawing and units are set up correctly!

Layout: Model Space v.s. Paper Space

Drawings are constructed in Model Space, visible in the Model tab in AutoCAD. There is also one or more Layout Tabs. These display the contents of a Layout, also referred to as Paper Space. As the name suggests, these are to create layouts intended for plotting (printing) your drawings on paper.


Switch to the Layout 1 tab which should be present by default in new drawings:

AutoCAD Layout1.jpg

By default, AutoCAD creates a white sheet with one viewport that displays the contents of your model space. More on that a little further on. First you have to setup your paper:

Page Setup

Click right on the Layout tab and choose Page Setup Manager...:

Page options.jpg

The following dialog will display:

AutoCAD PageSetupManager.jpg

AutoCAD selects the active Layout by default, so you can proceed by clicking Modify for the selected Layout. The Page Setup dialog will be displayed:

AutoCAD PageSetup PDF noPlotStyle.jpg

Here you can set paper sizes, the type of printer that will be used, etc. In this example we're creating an A3 Layout to be printed to PDF using the Adobe PDF Plotter.

  1. Select the Adobe PDF plotter (or other printer that suits your specific goal)
  2. Set the Paper Size to the desired format; A3 in this example
  3. Make sure the Plot Scale is set to 1 mm = 1 unit
  4. Choose the desired Drawing orientation

That's all for now. We will make the final (very important) configurations a little later on.


Your drawing should display one or more parts of your drawing that you've created in Model Space. This is done by means of viewports, which are literally a view port into your Model Space. By default AutoCAD creates one viewport for you.

You can move, scale and transform this viewport just like any other AutoCAD object in Model Space.

It's recommended to place your viewport object(s) in a separate layer.

Creating viewports

You can create a new viewport through the menu View > Viewports > 1 Viewport You're asked to pick both opposite corners for a rectangular viewport.

Activating a Viewport

When you double click inside a viewport it becomes active. The border is displayed as a thick line and the Paper-/Model Space indicator in the bottom switches to MODEL:

Model space.jpg

When you double click outside a viewport (somewhere on your paper), the viewport is deactivated and you're back in Paper Space.

Set viewport scale

When a viewport is active, you can use the regular navigation and zoom tools to select the part of the Model Space that is displayed and at which zoom level (scale).

To get your scale accurate, for instance at 1 to 200 (1:200), you can use the zoom command. We assume your drawing is set up in millimeters in Model Space.

  1. Type z [enter] for zoom
  2. Enter the scale: 1/200xp for a scale of 1:200. Don't forget the suffix xp which tells AutoCAD to relate the zoom scale to Paper Space units.
If your drawing was set up in meters instead of millimeters, i.e: one modelspace unit represents 1 meter, you should use 1000/200xp in the example above!

Hide the viewport border from the plot

When you plot your layout, it will also plot the border of the viewport (the lines of the viewport object). If don't want the borders to be plotted, you can use the Plot setting of the layer your viewport is in. It's assumed you've created a separate layer for your viewport(s).

Open the Layer manager and click the small plotter icon in the Plot column for the layer your viewport is in. A red line will appear through the icon indicating that the layer will not be plotted; the contents of the viewport will still be plotted though.

Autocad layer dontplot.jpg

Line weights and printing colors

There are several ways to print your lines in a certain color and line weight. In this tutorial we're using the method using Color Tables.

Color Tables

The Color Table translates the object's color into properties such as color and line weight. You can create a Color Table from scratch, but to make thing a bit more convenient, we will be using a pre-made Color Table. You can modify this one later when desired.

You can download our pre-made example From our website (zipped). The colors are set to correspond with the following line weights:

Color line.jpg Line color.jpg

Using Color Tables

First we have to make sure AutoCAD can find the Color Table we're going to use. The file needs to be in a specific location:

  1. Download the pre-made Color Table from our website and save it.
  2. Open the location where you saved the file and unzip it.
  3. Right-click the zwart-wit.ctb file and choose copy
  4. in AutoCAD go to File > Plot Style Manager

    Select plot style manager.jpg

    An explorer window opens:

    AutoCAD PlotStyleManager.jpg

  5. Paste the file you've copied earlier into this location
  6. That's it, AutoCAD can now locate the file. You can close the Plot Style Manager

Now AutoCAD can find the file, but it doesn't know yet that it should use this Color Table. So next we're going to assign this Color Table to the Layout(s).

  1. Open the Page Setup for your Layout.
  2. For Plot style table choose zwart-wit.ctb from the pull-down. If it's not there, you probably didn't copy the ctb file to the correct location.
  3. Optionally you could check Display plot styles if you want to see the effect of the Color table in your Layout view.

AutoCAD PageSetup PlotStyle.jpg

Object Color

So the color of an object determines how it will be printed. It's recommended to use the layer color to set the color for an object. So organize your layers and layer colors in such a way that it suits your desired printing properties.

You could set the color for each object individually, but then it's harder to make changes afterwards. For a few exemptions this may work, but avoid using 'per object' colors as much as you can.


Once you've completed the basic setup, you're ready to plot your Layout.

Preview the plot

When you've enabled Display plot styles in the Page Setup, you can get a rough idea about how your drawing would look when it's printed.

AutoCAD LWT.jpg

Using the LWT button in the bottom toolbar, you can enable or disable the displaying of line weights in your Layout.

To get the most accurate preview, you can use File > Plot Preview, or the Preview button from the Page Setup dialog.

Plotting a Layout

Click right on the tab of the Layout you want to plot. Choose Plot.

When you've selected a 'real' plotter, your drawing will be plotted as soon as you click OK in the Plot dialog. In this tutorial we've selected the Adobe PDF plotter. Once you click OK, your drawing is plotted to an Adobe PDF file. You will be prompted to select a location where to save the PDF file.

If you're using the Adobe PDF plotter, using the Plot preview function isn't really necessary. You can just plot to a PDF file and see if it's what you wanted.

Related information

Personal tools