Creating Schedules (Revit Architecture)

From TOI-Pedia

Introduction

Revit can provide overviews of various information contained in your model. These table-like overviews are called Schedules. Revit can calculate values for you in these schedules, based on the properties of your model and formulas your provide. You can, for example, calculate the area and length or count the number of specific objects, like the number of interior doors. All this is achieved by creating schedules.


Room schedules


You can define rooms in your plan. This is useful in your Plan Views, as each room gets a Room Tag that can be used to identify the room. But it is also used to create Room Schedules: an overview of all rooms in your project. You can list all kinds of additional room properties in a Room schedule, such as area or volume.

  1. Open your Floor Plan.
  2. On the Architecture tab, in the Room & Area panel, click Revit Room.png (Room)
  3. When you move your mouse pointer to your floor plan, Revit highlights each room in your drawing as it detects it. Rooms must be closed regions, bounded by model elements (walls etc) and Room Separation Lines.
  4. Click for each highlighted area that you want to create a Room for. Note that each room is identified by a number and a text (defaults to 'Room'). The number is automatically incremented by Revit.
  5. In the Ribbon, click Revit 2011 Modify.png (Modify) to end the command.
If Revit doesn't recognize a room, make sure it is closed entirely by walls, windows and doors and that the enclosing walls have set Room Bounding set to 'on' in their properties. Retaining walls have this option set to 'off' by default.

To add Room Separation Lines: On the Architecture tab, in the Room & Area section, click Revit Room Separation Line.png (Room Separator).

Revit creates Room Tags in each room. Double-click the 'Room' text of each Room tag to rename it to something useful. Each name results in a different fill-color. When you use the same text twice, both rooms will have the same color. (If you don't have a Color fill Legend you won't see any colors yet, you will need to create one to be able to see the colors)

Make sure to set the Visual Style of your Plan View to Hidden Line (using the View Control Bar). When you use Wireframe, the room fill color will run to the centerline of the walls, effectively overlapping your walls.


To create the actual Room Schedule:

  1. On the View tab, in the Create panel, click Revit Schedules.png (Schedules) and choose Revit Schedules Quantities.png (Schedule/Quantities)
  2. In the Category list, Choose Rooms. Click OK.
    Revit 2011 New Schedule Rooms.png
  3. In the Available Fields list, find (in this order) Number, Name and Area. Select each and click Add to add these fields to the schedule.
    Revit 2011 Schedule Properties Rooms.png
  4. Click OK

A Room Schedule View is created in your Project Browser in the Schedules/Quantities section. A Microsoft Excel like sheet structure is shown where you see the different values placed in columns.

Room Legend

You can add a legend to your plan that lists all colors that are assigned to rooms in the plan.

Revit Room Legend.png

  1. On the Annotate tab, in the Color Fill panel, click Revit Legend.png (Color Fill Legend)
  2. Click where you want the legend to be positioned.
  3. You'll be presented by a choice for the Color Legend. Revit can either assign different color based on the name of the room or the value of the 'Department' property that each room can have. If you didn't specify a Department value for your rooms, set Color Scheme to 'Name'. All rooms that have the same name, will get the same color.

When you select your Color Legend, you can use the Revit edit scheme button.png (Edit Scheme) button in the Modify | Color Fill Legends Tab to change the colors.


Wall schedules

We will give one more example of a schedule in this article, although many types of schedules can be created within Revit. A common schedule is a Wall Schedule, where you can calculate the length or area of the walls, but also the list the type or material and finish of the walls.

To create a Wall Schedule:

  1. On the View tab, in the Create panel, click the small arrow below Schedules and choose Schedule/Quantities
  2. In the Category list, Choose Walls. Give the schedule a useful name (i.e. Interior Walls). Click OK.
    WallSchedule 001.jpg
  3. In the Available Fields list, look for the useful fields (i.e. Family and Type, Length etc.). Select each and click Add to add these fields to the schedule.
    WallSchedule 002.jpg
  4. Click OK

A Wall Schedule View is created in your Project Browser in the Schedules/Quantities section. A Microsoft Excel like sheet structure is shown where you see the different values placed in columns.


Using formulas

You can use formulas to calculate values (i.e. total costs).

To add a calculated value:


  1. On the View tab, in the Create panel, click the small arrow below Schedules and choose Schedule/Quantities.
  2. In the Category list, Choose Walls. Give the schedule a useful name (i.e. Interior Wall costs).Click OK.
    WallSchedule 001.jpg
  3. In the Available Fields list, look for the useful fields (i.e. Family and Type, Length, Cost etc.). Select each and click Add to add these fields to the schedule.
    WallSchedule 004.jpg
  4. Click the Calculated Value button and give this value a useful name (i.e. Total Cost). Choose the right type of value from the drop down menu (in this case Currency). Click the ... button behind the Formula field to see the fields that can be used for the formula. Create the formula by clicking the field you want, type the mathematical operator (+, -, *, /, etc.), click another field or value, a mathematical operator, etc.
    WallSchedule 005.jpg
    Just make sure you end the formula with dividing by the number of units (in this example a price per meter is used and the length is in mm, so you have to divide by 1000. If Cost would be per m2 and you'd use the area (areas are in m2) you would have to divide it by 1 to get the cost per one wall.
  5. Click OK

A Wall Schedule View is created in your Project Browser in the Schedules/Quantities section. A Microsoft Excel like sheet structure is shown where you see the different values placed in columns. You will have to add the cost for the different walls. These costs are the same for all the Families of the same Type. You can set the cost for the Family Type in the Type properties or within the Wall Schedule View.


Formatting Schedules

To create a more workable Schedule it can be useful to format the Schedule. You can filter fields, calculate totals, etc.

In the properties window of the Schedule you can format the Schedule.

WallSchedule 003.jpg

By clicking any of the Edit buttons the Schedule Properties window opens.

WallSchedule 004.jpg
In the Fields tab you can change the Fields you would like to use in our Schedule.

WallSchedule 006.jpg
In the Filter tab you can add filters to (for example) only show walls longer than a set length or walls with a specific model name or description (if these Fields are selected).

WallSchedule 007.jpg
In the Sorting/Grouping tab you can sort our Schedule. You can also add blank lines between sorted categories. And you can choose to calculate totals. Un-checking the Itemize every instance will group the values in a sorted category. NOTE: grouping the the values will leave some of the values blank. You will need to change the Formatting of these Fields (see next part)

WallSchedule 008.jpg
In the Formatting tab you can change the formatting of the fields in our schedule. The most important item here is the Calculate totals option for some of the fields. Checking this option will calculate the totals of grouped values.

Export to Microsoft Excel

You can export our Schedule to Excel to do further calculations or exchange data with non-Revit users.

  • Click the Application Button, Export, Reports, Schedule
  • Choose a path and a file name to store the TXT file.
    WallSchedule 009.jpg
  • Click Save.
  • Leave the settings as they are.
    WallSchedule 010.jpg
  • Click Ok.


Open the Schedule in Excel

  1. File » Open...
  2. Set Files of Type to Text Files (*.prn;*.txt;*.csv)
  3. Browse to the location where you saved the TXT file. Select the file.
  4. Click Open
  5. Leave all the settings as they are and click Finish
Personal tools
Actions
Navigation
Tools