Indesign

From TOI-Pedia

Introduction

IndesignLogo.png

Indesign is an Adobe program meant for making multi-paged documents like reports and books. Templates for page layouts or text styles are easily made, using master pages and paragraph or character styles, respectively.


In CS5, new features include support for making interactive documents and simplified object selection and editing.


All elements of the graphic user interface will be introduced, together with the most important concepts that one needs to know to start working on a document in Indesign, like master pages and paragraph styles.


Basic Concepts

The following basic concepts like master pages and paragraph styles are important to understand and easily make layouts in Indesign.


Master pages

Pages of a new document

In contrast to Photoshop and Illustrator, in Indesign you can work on documents that consist of several pages. These pages can be duplicated, moved around and edited individually. It is even possible to combine several documents into a book – where these so-called chapters and their numbering can also be managed.

Using Master pages, layout templates can be made that can be applied to several document pages at once. On a Master page, you define a layout by placing text frames and graphic objects. It is possible to insert variables like the current date and chapter title, and special characters like page numbers that adjust automatically on the document pages. Several different Master pages can be made for one document if necessary. On the individual page in the document, the layout can then be edited and filled in with text and pictures.

Styles

Another important feature that facilitates the making of a layout are styles: formatting is saved as a style that can be easily applied to text or objects. Another advantage is that if a style is changed, all instances of that style will change accordingly.

Example of Paragraph, character and object styles


Paragraph styles define the formatting of a whole paragraph of text. Things like alignment, justification, leading (distance between lines), bullets and numbering and font size can be defined here. Hence, you can make styles for all the different text formats in your document like titles, the main body of your text and lists. The style can then easily be applied to a piece of text.


Character styles can be applied to single characters in addition to a paragraph style. They define a character property or a combination of character properties like color, size and tracking. For example, to make a single word bold, you can make a character style with the single property bold and apply it to any text, even if it already has a paragraph style, to make it bold.


Lastly, object styles define the appearance of an object, which can be a text frame or a picture. In the object style, the text wrapping of an object can be set.


Links

When inserting an image, it is linked to the original location of the file

When inserting external files into a document, it is normal to not fully embed them in the document, as it would become too big and impossible to handle. Instead, the file in the document is linked to the location of the original file.


The advantage is that the document can be kept smaller, as the image is not really included in the document. Also, it is possible to easily update the file by changing the original file or even re-link it to another file, all without having to change anything in the document itself.


Because the links are always connected to the file, it is important to collect all the used files in one folder. Otherwise, when the file or document is moved, the link might be broken –the file is not accessible anymore, leading to very bad quality.

To learn more about scaling and cropping images, read this article.


Linking text frames

Text frames

Text always needs a text frame, and can be inserted into any closed shape. The text as well as frame can be formatted. Text frames can be linked together. This makes text flow into the next frame when the previous frame is filled up.


Table of Contents

Table of contents

Defining paragraph styles has another advantage: it facilitates making a table of contents. For a new table of contents, you choose paragraph styles that will be included and on which level of the table they should appear. The table of contents will then be generated with the text that has the selected paragraph styles in the formatting specified.



Layers

Objects can be collected in different layers which can be locked and whose visibility can be toggled. It is for example handy to put elements that always stay the same like page numbers and graphics in one layer and lock it.


Objects

Object creation and formatting

As in Illustrator, you can create (vector) objects like rectangles, circles, lines and create shapes using the pen or pencil tool. However, as Indesign is focused on layouting, complex shapes are better created in Illustrator, then brought to Indesign. A shape can have a (combination of a)stroke, fill or gradient fill.


Grids

Baseline and Document grid

There are two grids in Indesign that help with making layouts: a baseline grid for aligning columns of text, and a document grid for aligning objects. Their settings can be changed in the preferences.



Graphic User Interface

Error creating thumbnail: Invalid thumbnail parameters
The Indesign Workspace and its elements

Around the workplace where the pages of a new document will be visible, several panels are arranged. Panels help you to work on and organize the document.


Select which panels are visible in the Window Menu
The different panel states

The application panel can be found on top with all menu items and view options. To the right, you can select a workspace preset: this shows and hides panels in the workspace according to the preset.


Panels are all the loose elements in the workspace that help you to monitor and modify your document. If a panel is not visible, you can go to Window in the menu and select it. In this menu, also shortcuts for different panels can be found. Panels can be freely arranged and grouped by extending, collapsing and dragging them.


By default, the tool panel is located at the left of the workspace, and work panels on the right.


The control panel is located underneath the application panel. It changes according to the selected tool and displays its settings and related functions.


Tool panel

The tool panel

In the upper section of the tool panel, all tools can be found: selection tools, creation tools, transformation tools and document tools.


Formatting options for objects can be found underneath. First there are squares for choosing if fill or stroke color is selected; with shortcut x the selection is also switched. Double clicking a square will bring forth the color picker.

Selecting fill(left) and stroke(right) of an object
The color picker

Clicking on the arrow will switch the stroke and fill colors and the two overlapping tiny squares revert fill and stroke to the default. The two tiny squares underneath this section are for selecting if a fill/stroke choice affects the formatting of the container or the formatting of the text within it.

Switching the Fill and Stroke styles
Switching between selecting Frame Style or Text Style


Choosing the formatting style of an object
Choosing the view of the document

Again underneath, the formatting square can be found. Holding down on it will enable the choice of formatting for fill and stroke. For fill, you can choose between color, gradient or nothing and for stroke between color and nothing. Double clicking on it will bring open the corresponding panel: the color panel for solid color, and the gradient panel for the gradient.

The last option in the tool panel is for switching between the different views.



Panels

The most important panels next to the control and tool panel will be explained here.

Panels


Pages: view of all master pages and document pages; switch between seeing document pages or master pages here.

Layers: view/hide, lock layers.Links: to keep the size of the document small, images are normally only linked to and not embedded in a document. Here a list of all images that have been linked to in the document with their status.

Links: all external files used in the document can be managed here; normally, files like images are linked to their original source and not embedded in the document.


Stroke: change settings of a stroke.

Swatches: save colors and gradients here.

Colour: choose a color and color mode here.

Gradient: modify a gradient.


Align: align elements and distribute them evenly.

Pathfinder: edit paths and objects.Effects: blending options, opacity and a list of effects an object has.

Effects: manage the effects of an object.

Object styles: make and edit styles for how objects (like images) behave.


Paragraph styles: make and edit styles for text paragraphs, like title and body styles.


Character styles: make and edit styles for single characters; can be used on words in addition to a paragraph style (like making something bold and changing a character’s color).


New Document

Settings for the new document

In order to make a new document, go to File>New>Document or press Ctrl+N. Here, for example paper size, orientation and if the document has facing pages can be set. All settings can still be changed later.

Navigate

To pan the new document, hold in the space bar and drag or use the hand tool. To zoom, use Ctrl+ and Ctrl-, alt+scroll or the zoom tool.

Views

Viewing and hiding guides, like margins

There are several ways to view pages and elements on them, like guides and grids. In general, all options for different views and showing or hiding elements can be found in the View Menu.

On the page, a purple square can be seen. This is the margin of the document and is useful for orienting yourself when making objects on the page. It can be changed in Layout>Margins and Columns. In order to hide this and other guiding elements on a page, hit Ctrl+; or go to View > Grids&Guides > Hide Guides.

The pasteboard

Around the page, a white area is visible. This is your pasteboard, where elements can be parked during work, so to say. It is not printed.


Normal view and preview of the document

In order to view only the pages themselves to see what the final document will look like, you can switch from normal to preview mode, using w, the previously mentioned icons in the tool panel or the menu via View.

Personal tools
Actions
Navigation
Tools