Rhino Surface Editing

From TOI-Pedia


Generating surfaces from curves

Loading the player...




Rhino surface from curves.jpg

Once you have the curves you can start generating the surfaces. Although you can make almost any kind of shape and create extremely complex designs the technique of generating this complexity is quite simple. This has to do with the fact that there are no more than 4 main techniques of generating shapes from curves. If you know these four techniques you can build almost anything.


  • The first option is the extrusion of a curve. This can be a closed curve like the example or an open curve. The form freedom which you have with this option is limited to the shape of the curve and the height of the extrusion.
  • The sweep 1 rail increase the form freedom because the direction of the extrusion can be varied. This gives you more possibilities to alter the final outcome of the shape than the straight extrusion. The shape can have different sections.
  • The loft is in this set one of the most powerful modelling options. You not only can change the section over the height of the shape but also the location of the sections. This option can generate very simple complex shapes.
  • The last option is the simplest. It will generate a surface on the inside of a closed flat curve







Rhino menu surfaces1.png

Although there are additional options available for generating surfaces, they are all related to these 4 principle options. All commands to create surfaces can be found under Surface








Surface > Extrude Curve

Rhino extrudecurve eg.png

Creates an extrusion of a curve profile. There are several options available which gives you a bit more choice in complexity of the generated geometry. The option of extruding along a curve differs from the Sweep 1 rail because the section does not align with the curve generating a non-continuous section. There are four ways in Rhino to create an extrusion:

  • Straight
  • Along Curve
  • To Point
  • Tapered










Surface > Sweep 1 Rail

Rhino sweep1rail eg.png

Creates a surface through at least one profile curve and defined by a single curve.











Surface > Loft

Rhino loft.jpg

Creates a surface between two or more selected curves. If you select the curves one by one, then the loft will folow the selected order. If you select the curves via a selection window, Rhino will use the most 'logical' order.












Rhino loft dialog.png

If you choose other options, click on preview to see what happens. Click on help for more information about the different options.












Surface > Planar Curve

Rhino planarcurves eg.png

Creates a planar surface from a planar curves. Curves are allowed to overlap but should always be closed to define the edge of the surface





Additional options for generating shapes from curves.

Surface > Sweep 2 Rail

Bi rail eg.jpg

It creates also a surface through at least one profile curve, but the surface is defined by two curves (rails). This option is in essence similar to the sweep 1 rail , the difference is that here we use two rails.

Rhino revolve eg.png








Surface > Revolve Creates a surface by revolving a profile curve around an axis. Similar to an extrusion along a circle








Surface > Rail Revolve

Rhino railrevolve eg.png

It also creates a surface by revolving a profile curve around an axis, but the surface edge is defined by an extra curve (rail).




NURBS Surface Editing

Loading the player...


Combining surfaces


The options of connecting surfaces and detaching surfaces are quite similar due to the similarities between NURBS curves and surfaces.


Rhino join.jpg

Joining: Like the curves surfaces can be combined into a single surface by joining them. If the surfaces connect at the edges they can be combined into a single object. You can use the Join icon on the toolbar.
















Rhino surface match.jpg

Surface > Surface Edit Tools > Match: this is a more advanced method of joining surfaces. They will align the surfaces so that the edges are blended together. There are 3 options available

  • Position – a hard connect
  • Tangency – surfaces blended together
  • Curvature – complete smooth transition between the surfaces





Rhino blendsurface eg.png
Rhino blendsurface dialog.png

Surfaces > Blend Surface: This makes a smooth connection between two surfaces. You can adjust the curvature or bulge by pulling at the control points. You can see a preview via the dialog box and do adjustments.















Rhino connect surface.jpg

Surface > Connect surfaces: Extends the surfaces till they connect.

Cutting surface


If you want to cut a curve in separate parts you will have to define the point where the curve has to be cut. This can be done by defining a point on the curve or one could use a cutting line. However defining a point on a surface is useless if it has to be cut. However a line can also be used as a cutting line on a surface. The line should define a closed area on the surface or a segment on the surface. Once the curve is defined you can use the Split or Trim function to cut out a part of the surface.




Trim and Split

Rhino surface curve trim surface.jpg

Edit > Trim: Removes selected parts of your surface. Edit > Split: The same as trim, but does not remove any geometry. Surfaces > Surface Edit Tools > Untrim: To undo the trim operation on a surface. First explode the surface to generate single surfaces!

Sometimes it is enough to draw a line over the object without it touching it and try to trim or split it. However this doesn’t always work. In that case an intersecting surface can be used as a cutting surface.

Generating curves on surfaces



Rhino surface intersection.jpg

Curve > Curve From Objects > Intersection: The curve will be defined by the intersection of two surfaces. The curve can then be used on both objects.







Rhino trim.gif

Curve > Curve From Objects > Project: The curve will projected according to the active view onto the surface. Although this a very effective tool, it can generate unexpected results. Especially if the curve will be projected onto the edge of the geometry.







Rhino curves directdrawing on surface1.jpg

Curve > Curve From Objects > Pullback: To resolve the problem of the behaviour of the curve when projected onto an edge of the surface. This option makes it possible to 3 dimensionally define a curve around a surface and let it be pulled onto the surface.






Interpolate On Surface.jpg

Curve > Free-Form > Interpolate On Surface: This option enables direct drawing on a surface.















Rhino surface split.jpg

Split: Select the Isocurve option to define a Isocurve on the surface. The Isocurve will function as an cutting line.

Curves from surfaces

Loading the player...




Rhino curves extraction 0.jpg

One of the key functionalities of curve based modelling is the possibility to extract curves from surfaces and reuse them as a basis for new geometry. This option makes it possible to keep building on existing surfaces, thereby enhancing the complexity and accuracy of the representation of the design.









Curve from surface.jpg

There are several options to extract the curves from a surface. As you will notice the isoparm direction on the surface will be key in the direction of the extracted curve.

There are various options to create curves from objects. Go in your menu: Curve > Curve From Objects

























Curve edge.jpg

Curve > Curve From Objects > Duplicate Edge: The edge of the surface can be selected. The edge for example can be used to build additional geometry.


Curve > Curve From Objects > Duplicate Border: The border of the surface is selected. This option can be useful to cap an object or use the curve to create the edge of the object in 3D.

Both options copy the edges of the geometry of the surface and are often used to form a basis for capping the geometry. The difference is that the Duplicate Edge option gives you the possibility to select the edges by hand. Not only the open edges but also the side edges of the geometry. Duplicate border will select automatically only the open edges of the geometry.








Curves from extractions


In contrast to the Duplicate option, the extraction of a curve depends on the definition of the shape by its isocurve. The option of extraction will enable you to extract curves from the surface.



Rhino curves extraction 2.jpg

Curve > Curve From Objects > Extract Isocurve: This option makes it possible to extract an isocurves from the surface. Please check the command line to toggle between the u or v direction of the isocurves. The isocurves can be then used as a basis for new geometry or as a cutting line on the geometry.



Curve > Curve From Objects > Extract Wireframe: The wireframe are the visible isocurves on the surface. When the command is executed all the isocurves and edges will be extracted and converted into curves. With these curves the surface can be rebuild or adjusted by adjusting first the curves and then rebuild the surface.






Rhino section.jpg

Curve > Curve From Objects > Contour: The contour option is a powerful tool to generate a series of sections through the geometry. This option is often used to "layer" a complex shape into series of flat surfaces

Additional Edit surface options


Rhino surface fillet.jpg

Additional edit options are similar to the options for the curves. This reason for this is actually quite simple. A NURBS 2D surface is , to place it simply, a 2D derivative of the 1D curve. Most of the mathematics behind the curve are similar to the surface. The result is that a whole range of curve tools are also applicable to the surface, taking in account that it has an extra dimension.



  • Surfaces > Extend Surface: Several options for extending a surface.
  • Surfaces > Fillet Surfaces: makes a fillet between two surfaces (rounding of the edge).
  • Surfaces > Chamfer Surfaces: This makes a bevel(straight edge) between two surfaces.
  • Surfaces > Variable Fillet/Blend/Chamfer > Variable Fillet Surfaces: As above but with more options
  • Surfaces > Variable Fillet/Blend/Chamfer > Variable Blend Surfaces: It is similar with Variable Fillet Surfaces, but has more control points
Personal tools
Actions
Navigation
Tools