Illustrator Basics

From TOI-Pedia
Author:S.Plomp

Introduction

Before you start reading this page, make sure you have a basic understanding of what Illustrator is and what the main differences are between Vectors and Pixels. This information is available in the Main Illustrator article.


This article covers the main features of Illustrator and briefly explains how they can be used.


This page uses abbreviations for the mouse buttons:

LMB: Left Mouse Button

MMB: Middle Mouse Button

RMB: Right Mouse Button

Color mode

When creating a new Illustrator file, one is prompted with the option to chose for either CMYK or RGB as color mode. The main difference between the two is the way it makes colors. RGB is based on the colors red, green and blue, whilst CMYK is based on Cyan, Magenta, Yellow and Key (black).

Printing RGB images on a CMYK printer or vice versa may result in unwanted color changes. When wanting to print something on a printer at the faculty of Architecture it is recommended to use RGB, since the available printers are optimized for RGB color printing.

RGB CMYK.jpg


More information on RGB and CMYK.

Graphical User Interface

When we fire up Adobe Creative Suite (CS) 3, you may notice that the Interface layout is quite different than what is was before. This new interface can be quite confusing, so if you're new with Illustrator, or prefer to use the old interface, you might want to set the interface layout back to the 'old skool' version by going to Window > Workspace > [Panel].

Cs3 interface.jpg Old interface.jpg

Your general layout consists of your toolbar on the left, your palettes (options and tools) on the right, and your artboard in the middle. Basically your workspace is unlimited, so it is allowed to draw art outside the artboard, but everything that is outside it will not be exported or printed.

Workspace.jpg


When loaded, Illustrator only has a couple of windows on the right side of the screen. Other windows can be found under the window menu. For example, the navigator window. Other handy tool-windows are the Type (text) and the Transform window. Depending on whatever window you want to use you can open or close as many as you want. When wanted to go back to the original Illustrator window configuration go to WINDOW > WORKSPACE > [Default].

Navigator window.jpg

Navigation

Navigation in your document is the same as in a lot of other Adobe programs. See below for a list of ways to navigate in your document. Obviously it is up to the user to find out which method he or she prefers.

Panning

Panning is the movement of the current view sideways or up and down. There are several ways to pan in your document, which are:

  • "SPACE + LMB", to move in every direction
  • Scroll-wheel, to move your view up or down
  • Dragging the red box in the navigator window

Zooming

There are several ways to zoom in your document, which are:

  • "CTRL +" to zoom in, "CTRL -" to zoom out
  • "ALT + ScrollUp" to zoom in, "ALT + ScrollDown to zoom out"
  • Using the navigator window; using the slider, the mountain icons or a exact % value


Navigation.jpg


Toolbox

In the toolbox (most commonly found on the left side of the screen), you will find all the tools necessary to start your first Illustrator drawing. Since this is an introduction to Illustator, we will only cover the basic tools.

Tool box.jpg


Selection Tool

By clicking on objects with this tool, you select these items for further use (like transform or changing colors). Hold SHIFT to select mutiple objects. You deselect by clicking anywhere where it is empty in your workarea or spaceboard. The selection will have the color corresponding with the layer it is currently in, the colored box around the selection is called the bounding box. Selection.jpg


Direct Selection Tool

You can use this tool to select components of a geometry, these could be either points or lines. Be sure to unselect any object before using this tool. If you do not deselect before using this tool, you will not select the components, but the whole geometry.

Direct selection.jpg

Pen Tool

With the Pen tool it is possible to draw a shape based on (anchor) points. With single clicking new points you create new, straight, lines between those points. With clicking, holding the LMB, and dragging it, you control the tangency (curvature) of the line. Thus with this option it is possible to create a line which has smooth ans straight segments.

Pen tool.jpg


Text Tool

The text tool allows you to create a text, by dragging a box you can create a text-box, with single clicking you create text without a box. When copy pasting it is recommended to use the text-box, otherwise the pasted text will be formatted as a single line. Also the boxed text version gives a better control over the alignment of the text (left, right, middle).

Text tool.jpg


Shapes Tool

By holding this button pressed for a short moment, you unfold the extra shapes. You create a new shape by LMB-clicking, and dragging the shape to its size of preference. Holding the SHIFT button while creating lets you create bi-symmetrical shapes or snap to 90 degrees. With single clicking a new shape in your work area you get prompted for the exact measurements.

Shapes.jpg

Line Tool

With single clicking one is prompted with the exact measurements and angle of the new line. With LMB-click and dragging, you can visually create the length and angle of the new line. With SHIFT you can snap the new line to multiples of 45 degrees.

LineTool.jpg

Live Paint Tool

The Live paint tool lets you fill enclosed area's with a color or gradient like the famous paint-bucket tool in Photoshop and even Microsoft's Paint. The only difference is that Illustrator requires a Live Paint Group to be created on the objects first. Select the objects and then click on them with the Live Paint tool. After a Live Paint Group is created, you can fill areas marked with a red border with a fill color by clicking within the highlighted selection.

LivePaintBucket.jpg

If you have difficulties creating a Live Paint Group, refer to Live Paint Group Troubleshooting.

Fill Color

When an object is drawn it can be left empty or it can be given a color. With double clicking the fill color icon you can chose your own fill color. When no fill is desired you can choose the "none" option, which can be recognized by its red diagonal in the white squared icon.

Stroke Color

The stroke color lets you decide the color of the line or border of your object. Double click the stroke icon to chose the color. When no fill is desired you can chose the "none" option, which can be recognized by its red diagonal in the white squared icon.

Fill Stroke color.jpg


Transform

Object Boundingbox

When an object is selected a highlighted square with handles is shown around the object. This so called bounding box can be used to transform an object. Possible transformation are: Moving, Scaling and Rotating.

  • Move the object by either clicking on the fill or stroke-line and drag it around while holding LMB pressed. Pressing SHIFT while moving makes the movement snap to a straight line.
  • Scale an object by pulling on any of the bounding box handles. Pressing SHIFT while scaling results in a proportional scaling, both sides will remain in the same proportion.
  • Rotate an object my moving the mouse in the area of a corner point, a small rotation icon will appear. Pressing SHIFT while rotating snaps the rotation to multiples of 45 degrees.

BB move.jpg BB scale.jpg BB rotate.jpg


When wanting to move an object while the bounding box is in the way, you may click the handles by accident, which may result in unwanted scaling. If you do not want the bounding box to show, press the CTRL key, which makes the bounding box disappear.


Transform menu

In Object > Transform in the menu bar the Move, Scale and Rotate transformations are available plus some additional transformations. You can use these transformations by selecting the target object and selecting the transformation in the above mentioned menu.

Use the shear transformation to skew an object or text (to make italic). Enable preview in the shear dialog to see the result of the entered value.

Use the reflect command to make a mirror object of the selected item.

Transformation.jpg


Shear.jpg


Reflection.jpg


Smart Guides

Smart guides in the menu

Since Illustrator is a vector based program, it has the ability to draw very precise. To take full advantage of this precision one can use the Smart Guides. This is the Illustrator equivalent of AutoCAD's Osnap tool. You can activate the Smart Guides under the VIEW menu.

When the Smart Guides are activated you will notice that all sorts of information starts to appear at the mouse pointer when approaching existing lines and drawings. Pay attention to what the words say, because they help you distinguish between snapping to anchor points (end- or corner points) or paths. Also it will notify you if a certain point is at 0 or 90 degrees (like the Polar option in AutoCAD), which is called align.


Moving

Smart Guides can be used to move certain objects or anchor points to other anchor points or somewhere along a path. It also helps you to pick certain objects up at points or paths.

Smart guide move.jpg

Scaling

While scaling, Smart Guides can also be used to scale objects the same size or to certain heights. All you need for this is a reference geometry to snap to. Just drag one of the bounding-box handles (with holding SHIFT for proportional scaling) to a reference point.

Smart Guides and scaling do not work with the top-right handle of the bounding box.

Smart guide scale.jpg

Tracking

While creating a new path (line) one can also use the smart guides, whereas existing geometry can be used as a reference. An option comparable to AutoCAD's Otrack. If you want to make a new point at a virtual (non existent) extension intersection of two lines (see below example), you move your mouse (without clicking) from these reference points to the virtual intersection point. This process is called tracking.

Smart guides tracking.jpg


Also Smart Guides automatically snaps to multiples of 45 degrees. You can add different degrees by going to Edit > Preferences > Smart Guides and Slices.


Line Appearance

Another thing that makes working with vectors the preferable choice over working with pixels is the easy of changing. We have already seen that fill color and stroke color are easily changed. But there are more options to change the appearance of a line. The following options even more show that Illustrator is very suitable for making presentation posters.

Dashed lines

In Illustrator it is fairly easy to make a dashed or dotted line. Go to the STROKE menu on the right side side of the screen. Click on the small diamond in the stroke tab, this will unfold some extra stroke options. Now click on the item(s) you want to make dashed, check the dashed line box, and enter values for the lines or dots and gaps (holes between the lines). Obviously depending on how big your drawing is, you should choose small or large numbers. Make your own variation or look up official patterns.

If you want to make a continuous line from a dashed line, select that line, and uncheck the dashed line box in the stroke menu.

Dotted line.jpg


Stroke weight

Also in the STROKE menu on the right side of the screen is the weight option. Here you can give a certain weight or thickness to a line or shape. Select the object you want to change, then type in a number numerically, use the arrows to in- or decrease the value or select one from the list.

Standard the weight is on points (pt), but you can also use millimeters (mm). Just type in you preferred mm value, and press enter. However the value will nevertheless be displayed in points. if you want to have it say mm you need to go to EDIT > Preferences > Units and Display performance, where you can change the stroke unit to millimeters.

Also you might encounter problems with typing in values by hand, this could be due to your international settings in Windows. If it gives an error, try using a point (.) instead of a comma (,) to separate the decimals.


Weight.jpg

Transparency

In the transparency window (two tabs to the right from the stroke menu). You can change the transparency of objects. Unlike Photoshop you do this per object, and not per layer. You can also use groups (Object > Group) to make the process go faster.

If you want to change only the fill transparency, and not the stroke, you need to select the object and select its fill in the Appearance (Window > Appearance) menu.

Transp.jpg


Arrowheads

Adding arrowheads is done after the creation of the line you want to add the heads to. Select the line, go to Filter > Stylize > Add Arrowheads. Select a scale (size) and a type for the beginning of the line and for the end of the line.

Keep in mind that the head will add to the length of the line, thus extending the line. Also if you want to change the color of the head and not the line, you need to ungroup the object. After adding the arrowhead(s) the line and head become a group. Ungroup by selecting the group, Object > Ungroup.

Add arrowhead.jpg


Layers

Working in layers in Illustrator is of the utmost importance. Every single line that you draw will be a separate layer, thus it is not uncommon to have over 50 layers in Illustrator. To keep everything manageable, Illustrator has a more advanced layer manager than Photoshop.

The Illustrator layer manager has the ability to nest layers. Nesting means layers inside layers. Thus it is fairly easy to create a hierarchical structure in your layer system, where you work with sub-layers in sub-layers. Comparable to the regular directory system in Windows, where folders are placed inside folders.

Also using filenames as opposed to generic names like "path" and "group" help make the layer system more manageable.

With the use of the meatball (the circle behind the layer name) you can select the object in that layer. When an object is selected in the work area, you will see the meatball being highlighted inside the layer manager, displaying that it is that object that is selected.

Obviously you can lock layers and toggle visibility with the corresponding icons before the filename. New sub-layers are automatically created when drawing something in your work area. But the icon "make new layer" lets you create a new top layer, where can drag objects into. Moving layers is done by LMB-clicking the layer, and dragging it to the preferred location.

Layers illu.jpg


Clipping Masks

Example of a clipping mask in action

You can hide parts of an object by applying a clipping mask. You can draw a new object or use an existing one. Place the shape over the part of the object you want to keep visible.


It is important that the object that is to be used as clipping mask is 'on top'. Use Arrange to make sure: RMB-click the object and choose Bring Forward/Bring to Front.


Select both the object that is to be used as a clipping mask and any object on which the mask should be applied. RMB-click and choose Make Clipping Mask

Personal tools
Actions
Navigation
Tools