Modeling Villa Savoye

From TOI-Pedia


This tutorial will give you an insight on some advanced polygon modeling options in which we will use lines. We will be modeling the Villa Savoye in Vichy, Paris designed by Le Corbusier.

Villa savoye.jpg

We will use floor plans, sections and pictures. The floor plans are drawn in AutoCAD, which we will exported to Maya. Elements which we will encounter are; Create polygon tool, planar, extrude, create curve, duplicate surface curve, attach curve, component mode

You can use a pre-made AutoCAD (2006) drawing of Villa Savoye for this tutorial. You can download it from our website.

Project setup

When using maya you will use a lot of different files, and a lot of files will be generated. To keep everything tidy (and effective) Maya works with a project structure. This means that a lot of subfolders are placed in a main folder, each for different types of files. It is always very important to set up your Maya project properly; failing to do this will result in frustrations later on.

How to set up a proper project is explained here.

Analyzing geometry

When you model a building it is important to analyze the building geomtry, so you know what shapes you will encounter when modeling.

Axometrie savoye.jpg

When we look on the outside of the building, we see a variety of shapes from straight and sloped to curved. For each shape there is an optimal tool or working method. When working on bigger or more complex buildings you want to work as efficient as possible. So it is important to learn to use the right tool for the right job.

When you analyze the geometry it is good to keep in mind for which purpose you are making the model. Is it just for exterior renders? Do you want some detailed close-ups? When using it for exterior shots you don’t have to model the interior too detailed. But remember when making renders through a window you will see some of the interior.

In this tutorial we will also model the interior because we want to make interior shots.

Autocad Lines


Maya 8.5 does not support autocad lines properly on import. That is why we have to use at least Maya 2008 to import the CAD lines.

How to do import Autocad lines in maya 2008 is explained here

multiple floors

For this tutorial we have one cad drawing with multiple layers. 3 floorplans, one for each story. So we will import 3 drawings into Maya, and put them on the correct height in the work space,

When you place floor plans over each other in AutoCAD or Maya, you can easily check for alignment faults, like misplaced columns and walls

When you follow the steps described in the import section you will get one level at a time in you scene.

Import savoye 1.jpg

After rotating, and aligning it is wise to put each level in a separate layer. You do this by first making a new layer. Click on the 'create new layer' button in the upper right corner of your layer box. Choose a good name and color for your layer, in this case it is: 'level_1' and the color is dark blue. Select the lines, right click on the layer and choose 'add selected objects'

Add line to layer.jpg

After this we continue with the other levels. Give each layer a different color and name. In the end you will get a view like this:

3 layers in model.jpg

Create polygons with lines

Now we have imported the plans we can use the lines to make polygons. This way we can make very accurate models, so that we don't have to bother about misaligned elements in our model. There are different tools in Maya to create polygons out of lines. The most important ones are explained in this tutorial.

Make walls with the Create polygon tool

The most common way to make a simple polygon is to use the Create Polygon Tool.

With this tool you can simply draw a 2d polygon shape. This shape can be extruded to get the desired polygon. This tool is very handy for straight elements like walls. We will use it to make the straight walls in the first level.

To get accurate shapes we have to snap the tool on the lines. Normally the snap to point tool doesn’t work on lines. That is way we have to activate the edit points of the lines, so we have something to snap to. You activate them by going to Display > NURBS > Edit Points. Why NURBS? because lines belong to the NURBS family.

Activate editpoints curves.jpg

The edit points are displayed as small yellow crosses on the lines, on which you can snap.


We start with outer wall in the back of the ground level. It is a t-shaped element. We will draw the outer wall and the inner wall which runs perpendicular to it in one action.

Wall groundlevel.jpg

You always have to think for which purpose you are modeling. In our case the outer and inner wall can be made out of one polygon. But if you are making a model where you want to put the walls in different layers, you of course should draw them separately.

Select the create polygon tool, by going to the mesh menu and then the polygon tool. Remember to set the option box in the status line to polygon, like displayed in the image, otherwise you will not find the mesh menu.

Createpolygon tool1.jpg

start to click counterclockwise on each of the editpoints. After clicking the last point you can hit the enter key to close the polygon. You should not try to close it by clicking again on the first point of your polygon.

Create polygon wall.jpg

Now we have a 2d polygon shape of the wall. To get the actual wall we have to extrude this shape with the extrude tool. Select the polygon and then go to Edit Mesh > Extrude. Now some new handles appear. Click and drag on the arrow for the y-direction so you extrude the face in positive direction. In the channelbox on the right of the screen you see that by dragging the extrusion you change the 'local translate Z' value. Adjust the value to the height you want. We choose 2.75 meters.

Extrude polygon wall savoye.jpg

With this method we can make all the simple straight walls on the first level. Even some more complex forms are possible, as long as it is not curved. In the picture below you see some other wall elements of the ground floor.

Polygon groundlevel savoye.jpg

Make walls with the planar tool

For curved shapes, like the piece of curved wall on the ground level, the create polygon tool is not sufficient. In this case we will use the Planar tool.

The planar tool will create a planar between selected lines, the same as when using NURBS. Instead of choosing a NURBS surface we will create a polygon surface. But first we have to select the lines we want to use.

Select the lines of the piece of wall which has a curved angle. As you see in the picture, the lines have to make a closed region. They don't have to be joined, as long as they are all in one plane. If you miss some lines you can draw them with the curve tool and the snap option. To make selecting all the lines easier you can group them.

Planar group lines savoye.jpg

With all the lines selected we go to Surfaces > Planar and choose the option box.

Select planartool.jpg

Now we see the option box. Because we want a round shape we choose a cubic degree. And the output geometry is Polygon. We have a lot of options for the tessellation, which tells the program how to make the planar. It is important to choose the right settings here because you can get very bad results with a lot of hard angles in it, or a smooth result with an unnecessary amount of faces. We choose standard fit. Copy the settings from the picture and apply. This will give us an satisfactory result. Play with the settings to understand them, so you can apply them to different shapes.

Plannar optionbox savoye.jpg

After applying we have a polygon face, So now we can extrude it the same way as we did with the previous faces. For 'local translate Z' value we again choose 2.75 .

Planar extruded savoye.jpg

With the Planar tool and the create polygon tool we can make all the walls of the ground floor. The result looks like this:

Groundlevel walls savoye.jpg

Make walls with the loft tool

The entrance on the ground level exists out of a big round glass window. If we look closer to some pictures we see that the window exists out of a lot straight window segments. On the pictures it isn't clear how much there are exactly, so we have to make an estimate. On our imported cad drawing we just have two curved lines ( which together don't form an arc!). Combine the lines to get one line, by selecting them and go to Edit Curves > Attach Curves. Select the Option Box and make sure the Attach Method is set to Connect and Keep Originals is turned off. Click Attach. Now the two lines are one.

Attachline savoye.jpg

We have to give the glass a thickness, so we will offset the line by 0.05 units. Select the line and go to Edit Curves > Offset > Offset Curve and select the option box. Use a value of -0.05 in offset value. By using this value the line will offset to the outside.

Offset line savoye.jpg

We could attach 2 extra lines two close the region, and use the planar tool. But instead we will use the loft tool. A tool which most people associate with NURBS, but polygons can also be created with it. So select the two lines go to Surfaces > Loft and choose the option box. Set the output geometry to polygon. You'll see that the extra options are the same as with the Planar tool. Instead of standard fit we choose general this time. This is the best option because we want to have an uniform division of faces on our polygon. The u and v values are important. The u value will affect our division in the length. The V value will affect the division in thickness. So we set the V value to 1 and the U to 50. This means that we will get 50 faxes with according edge.

Loft polygon savoye.jpg

When we extrude the face we have a wall which looks round but is build up out of 50 faces, which will give a more realistic representation of the window in the model. The exact number of glass panels which is used for the window cannot be seen from the pictures we have, so we estimate 50.

Glasswall polygon savoye.jpg

The window is also in front of the entrance, we have to clear the entrance. We use a Boolean operation, the difference tool. Make a poly cube and drag it to the front wall elements which are part of the entrance. Drag the vertices in the compound mode to the right edge to get a nice result. Select the window poly and the cube and got to Mesh > Booleans > Difference. Now the entrance is free again.

Boolean window savoye.jpg

Now we have to add the window frames. We see that the window has one horizontal line at about 1.20 m above the ground. To make this part of the window frame we repeat the steps of the window. First we make a new line on the outside of the window, with the offset tool.

Select the most outer line and offset it by 0.05 units. Also offset the inner line 0.05 units to the inside. Now we have 4 lines us the most inner and most outer line to loft. Use the same settings as for the window. Now extrude the faces to a height of 0.05 units. Place the poly on the appropriate height.

Windowframe savoye.jpg

When selecting lines, the existing polygons can be in the way. To solve this you can temporarily hide them. To do this go to the show menu in your panel (this is the white menu bar just above your viewport). Now you can deselect a lot of things including polygons.

Now it should look something like this.

Windowframe horizonta savoye example.jpg

Now would be a good time to change the window colour into something transparent, so you can distinguish the forms better. Make a new Phong material, make it almost completely transparent and apply it to the window.

The next step is to make the vertical stiles of the window frame. It looks like we have to place them on half a circle, but this is not the case it is a non-uniform line! A simple copy and rotate will not do the trick. We could manually copy each one an place, and rotate it in the right way. This takes some time because we have to do this 50 times. Another way is to use Maya's animation capabilities:

Start with creating a new polygon cube with a height of 2.75, width of 0.05 and length of 0.15. Place it on the end of the window. Put the pivot point on the middle line of the window, like shown in the picture.

Windoframe vertical animatedsweep1 savoye.jpg

Set the time slider to 50 frames. Set the key of your poly by pressing s ( when selected) the channelbox will become orange. Now go to frame 5 and rotate the vertical poly by -180 degrees around the y-axis. You see that it will go to the other end of the window. Set the menu lay-out to animation. Go to Animate > Create Animated Snapshot. You see that 50 new polygons are created. But they are not yet in the right place. We do not have to place them all, because some of them stand in the garage, now windows are needed there

Windoframe vertical Animatedsweep2 savoye.jpg

To get the others in the right place we have to use the snap tool, and center pivot function. Working in top view gives you a good overview. Select the first poly, center the pivot with Modify > Center Pivot. Drag the poly on the crossing of the center line of your horizontal window frame and of the face of the glass. Repeat this for the other vertical frames. You see that the polygons align in the correct angle on the glass surface, if this is not the case check if you drag the right polygon to the right place.

Windoframe vertical place savoye.jpg

Windoframe vertical placing savoye.jpg

When finished, you have all the vertical frames on the right spot, but not yet on the right height. To do that, select them all in a side view. Move the pivot to an upper edge. Move them all to the edge of the glass. Delete the unwanted polygons. The result should look like the picture below.

Windoframe vertical excesspoly savoye.jpg

Use a Boolean operation on the excess glass and framing. Now the window is finished.

Windoframe finished savoye.jpg

Make stairs using lines

The stairs of the Villa Savoye are interesting. The rounded form is best made using lines. The stairs have multiple volumes which together form the stairs.

Villasavoye stairs.jpg

We start with the lowest one, which is the straight balustrade. Select the inner and outer lines which form the arc. Loft them. now extrude them to 0.6 units. repeat this with the two straight volumes. The result should look like this.

Stairs wall.jpg

The next step is to make the railing. We use the same lines used for the balustrade. Attach the outer lines together. Offset them 0.05 units to the center. Now we have the path on which we will extrude. Place a circle on the starting point, align the circle so that it is perpendicular to the line. Move the line and circle to a height of 0.8.

Railling straight.jpg

Loft the circle over the path, Surfaces > Loft (Option Box). Copy the settings from below. We again make polygons. It is important to use the proper U and V values to get a smooth result. Now we have the first part of the stairs

Railling straight optionbox.jpg

Next we make the sloped part. Copy the straight part you have just created. go to component mode. Select the 4 vertices on the side which will be lifted. Click on CVs in the channelbox. Enter a y-value of 1. The result is the sloped balustrade. Use a copy of it for a Mesh > Booleans > Difference operation to eliminate the excess railing. Copy and place the balustrade for the connection to the first floor.

Stairs balustrade sloped savoye.jpg

The second part is more difficult, because we have distort the lines in 3d space. To achieve this we have to know the height we have to bridge and we have to use the side views to distort the line accurately. The height difference is 0.75. Select the line which forms an arc. Go in component mode. Put the high end to a height of 0.75 and move the other points to form a fluent s-curve. Copy the complete line and move it 0.6 units up.

Stairs line distort duiplicat savoye.jpg

Now we can loft the lines. Choose polygons. And a U and V value to get the proper result. The polygon has to be extruded to the fit the thickness of the balustrade. Extrude it and use the snap function to get a proper alignment. It could be necessary to reverse the normals of the face before extruding.

Stairs extruded bordes.jpg

Next step is to make the smooth bottom of stair. For this we will use the same arc line as for the balustrade. To the center of the staircase the bottom becomes vertical. For this we will draw a vertical line. Use the arc as starting and end point of the line. Use Modify > Center Pivot. Now enter for the X- and Z-value 0. The line becomes straight en positioned on the right spot.

Stairs bottomline ofsset.jpg

Loft the two lines, tessellation method: general. Use a high u-value (50). The result is a smooth bottom surface. The rest of the bottom surface can be formed by making steps, which is already explained.(see Modeling a winding stairs in the Modeling an orthogonal pavillion tutorial.

Stairs bottomline lofted.jpg

Next is the railing for the rest of the stairs. For this we will duplicate the surface curve of the balustrade. select the complete balustrade. Duplicate the inner curve of the straight pieces. For the round part we already have a line so we don't need to duplicate that. Attach the lines together. In the option box choose Blend as attachment method. choose a value which gives a good curve radius. the result looks like this curve

Handraill attachlines.jpg

This line we use again the same way as we did with the other railing. The result is a finished stair.

Stairs finished savoye.jpg

Making the ramp using lines

The ramp is easy to create. Select the two lines for the first part of the ramp. Loft them, only one face is needed. Extrude the face with 0.2 units. Select the 4 vertices on the end which faces the wall. Click on the cv-points in the channel box. enter a value of 1.375 for the Y-value.

Ramp sloped savoye.jpg

For the balustrade we can duplicate a surface curve of the ramp. Copy this and move it 0.1 unit in negative x-axis.

Ramp duplicate surfacecurve savoye.jpg

Again loft this. Place it to the underside of the ramp and extrude to the right height (0.8). Now we don't have to change the CVs.

Ramp balustrade savoye.jpg

the straight floor between the two ramps is made the same way as the ramp, but now we don't have to change the CVs

We can copy the ramp and balustrade for the second part. Rotate it 180 degrees and align it. Also align the vertices of the balustrade, so that the don't stick out in to the walking way.

Ramp align balustrade.jpg

with that the ramp and rest of the construction of the ground floor is finished.

Ramp finished.jpg

First floor

We can construct the first floor the same way we did the ground floor. Choose the tool which suites you best and extrude all the walls. for example the create polygon tool for the straight polygons, and the planar tool for the round ones. The result should look like this.

Firstfloor savoye.jpg

Next we make the openings in the floor. The stairs and ramp need a opening. We use the Mesh > Booleans > Difference operation for this..Use the create polygon tool and snap to trace the shape which we will use.

When there are a lot of lines an polygons in your way, tracing can be difficult. Select the objects you need and select in our viewpanel Show > Isolate Selected > View Selected. Now all the other objects are hidden and tracing will be easier.

Now extrude the shape so that it cover the section you want to Boolean. It should look like this.

Firstfloor boolean savoye.jpg

Use Mesh > Booleans > Difference. Repeat this for the opening of the ramp. The result should look like this

Firstfloor opeings savoye.jpg

Now we can copy the stairs and ramp form the ground level to the first floor.

Firstfloor copy stairs savoye.jpg

Next the windows. One window is 1.15 wide and 1 unit in height. And there are 15 windows in one side. The distance between the windows is 0.05 units. Make a polygon cube width the right dimension and duplicate it 14 times over a translation of 1.2 units. Use The Booleans > difference operation on the windows.

Combine all the cubes of the windows together before you Boolean them. This speeds up your operation.

The result for all the sides is this.

Firstfloor booleanwindow savoye.jpg

Select the lines of one window in component mode. Duplicate the surface curve like described earlier.

Dirstfloor duplicated sufacecurve savoye.jpg

Planar them to create a window face. Extrude them to a desired thickness, for example 0.03. Copy this planar for all the windows.

apply a transparent shader to the windows, this help you to keep the overview during modeling .

Second floor

The last floor is the roof level. Make the polygons the same way we did earlier. Check if the stairs are aligned properly.

Top floor savoye.jpg

The end result should look like this

Final savoye.jpg

Now we modeled the Villa Savoye. You can continue to shade the model or to make it more detailed for more interior shots.

Back to Modeling with polygons

Personal tools