Modeling with polygons

From TOI-Pedia


Theory

Introduction

The objects we create in Maya, like real objects, have certain properties which define their possible use. It can be compared with the different use of cardboard , MDF or clay in making a physical model. Each material has its own properties , ways how to modify it and the forms you can create with it. You would not use a saw on clay and you would not use MDF for making a model with a double curved surfaces. If we want to design in the computer we will have to know the properties of the geometry we use in the design process. It will define what kind of form can be generated, the possibilities of altering the form and the accuracy of the form ( interesting if you want to digitally manufacture the object) We will use polygons for the first two workshops.

The polygon is a very simple description of geometry. Its form is defined by a set of coordinate points (vertices). A set of coordinate points are maybe interesting for the computer to work with, we only see a lot of dots. To make the form visible they added between each three points a triangular surface, which is called a face. These faces together between all the coordinate points are what we are seeing. This structure has a substantial influence on what you can do with the geometry.

Polygon is a straight forward description of geometry in 3D.

  • The shape is defined by its coordinate point or vertices. The vertices will define the shape of the geometry
  • The surface of the geometry is defined by the planar triangular faces. The faces will define the surface of the geometry
  • The edges of the geometry are the edges of the faces. The edge is always a straight line


Polygon components overview.jpg


Advantages:

  • Possibility of describing volumes
  • Less memory intensive
  • Straight forward mathematical description
  • Commonly used geometry type

Disadvantage:

  • The curvature is only approximated by the face between the vertices
  • High poly count necessary for curved shapes approximation


Applications:

  • Modelling Cartesian architecture
  • Architectural visualisation
  • Architectural interactive virtual visualisation
  • Geometry for analysis
  • Geometry for Rapid Prototyping


The straight forward description of the polygon as a set of coordinate points makes it especially suitable for analysis and rapid prototyping. Distances, areas, volumes and angles can be calculated based on the position of the coordinate points. The low memory requirement for display makes polygons the favourite geometry for virtual reality environments like web based interactive virtual environment and games. The possibility of generating volumes makes polygons faster in modeling of straight angled surfaces

The disadvantage of not being able to describe curved surface accurately is a major drawback in designing with polygons. Because there is always a straight edge between two coordinate points (vertices) the curvature will always be a crude approximation. This one of the reasons polygons are not used in more complex designs with curved ore double curved surfaces.


Polygon voorbeeld1.jpg


The geometry

If you want to design in the computer you will have to know the properties of your design environment, its possibilities and its limitation. Not only the geometry type is of influence on the design process. Polygons for example have the problem of not being able to accurately describe curved surfaces. The form you start to design with is also of influence on the possibilities of generating a formal description of your design. There are 3 different kind of geometry forms you can start from.

Geometry form.jpg


The first one is the volume or predefined volumes ( primitives). If we start using volumes as a basis for modeling our design we have the advantage that the geometry is already defined in 3 dimensions. We can alter our 3D geometry by deforming it ( make a cube into a rectangular box) or making a combination of different kind of 3D objects ( subtracting one box from the other to create a hole) This starting form however has its limitations because the 3 dimensions are already defined from the start. The topology , organization of the surfaces, of the form predefined. Although complex objects can be made with this kind of geometry it can be quite difficult.


Volume form.jpg

The second more flexible geometry to start with is the surface. If we can generate a surface, we can define its form in two dimensions. By extruding the form in the third dimension we can generate a 3 dimensional object. This extrusion process however is often limited to a simple straight extrusion. So the influence on the 3rd dimension is limited. The maximum freedom in this case is primarily limited to two dimensions. This makes this form especially suitable for geometry with a complex section and a simple extrusion, like a facade or a steel beam.

Vlak form.jpg


The third option is the most flexible and is widely used in digital design. In this case the basic form is a line or a combination of lines. The strength of the use of lines as a start for geometry is the fact that the line not only can define a surface in two dimensions ( a complex surface ) but by using a combination of lines the third dimension can also be defined by a line. This method of constructing complex geometry with the help of lines is called curved based modeling and is widely used in other industries like product design, car design and in the aero-space industry.


Curve form.jpg


In this course we will use all the three techniques. We will start with the creation of volumes and the techniques how to modify them.

Polygons menu's

When you are modeling with polygons, you will use the Modeling menu set. The File, Edit, Create, Display and Select menus are the same for all menu sets, but the others change depending on the selected menu set. When you select the Modeling menu set, the polygon menus: Mesh, Edit Mesh and Mesh tools menus are available.

Polygonsmenuset01.jpg

Creating geometry

Creating objects using primitives

create

You can create polygon primitives by using the create > polygon primitives command. It can be convenient to turn on Interactive Creation in the bottom of the polygon primitives menu.

Create01.jpg

When you now double click somewhere in your view port a primitive with the standard dimensions will be created. You can also create the dimensions of the primitive now interactively by clicking the required dimensions. This can work really well in combination with the snapping tools. If you don't want to use the interactive creation and you want every new primitive to appear at the (0,0,0) point in your view port with the standard dimensions, you can turn it off (and on) by clicking create > polygon primitives > interactive creation.

Create02.jpg

Toolbox

Selection tools

There are a couple of ways of selecting objects in Maya. If you are still in another tool, make sure that the selection tool in the toolbox is selected or press Q on your keyboard. Select an object by clicking on it. By holding the Shift key it’s possible to select multiple objects. Clicking and dragging a window around the objects is a faster way of selecting multiple objects. With the lasso tool in the toolbox you can drag a non-rectangular selection around the objects. To remove objects from the selection hold the Control' key while clicking the objects.


Selection Tools.jpg

Transforming Objects

When an object is selected, it can be transformed. To move, rotate or scale, select the particular tool in the toolbox. Click and drag the manipulator on the colored axis of choice to perform the desired transformation. When selecting one axis, the transformation is only performed on that particular axis. For transforming in all directions click the yellow icon in the center of the manipulator


Transformation Tools.jpg


For example, if we want our object to scale in the z-axis, we select the object, we then select the scale tool in the toolbox, the manipulator is shown and we click and drag the blue cube to scale the object.

The transformations are numerically shown in the ‘Channel Box’ on the right. You can input the transformation values manually here. So the use of exact measures is possible this way instead of dragging the manipulator a random amount. For mirroring objects it is possible to input a negative scale value in the channel box.


Mirroring.jpg

Note that all the transformations you do to objects will be done with the pivotpoint as base. If your pivotpoint is placed in the center of an object it will be scaled, rotated and moved from that point, if you want to transform your object from another point (for instance from one of the corners), you can move your pivotpoint (see under the section editing geometry below)

Channelbox

The Channelbox is on the right side of the screen. In this menu you will find all the properties of the selected object, and you can change those properties. If you apply a certain operation on an object, Maya will remember this. This is called the construction history of an object and that is also shown here.

Interface channelbox.jpg

If you create an object in Maya it will automatically get a unique name. When you are building a large building or model it can be useful to change the standard name of an object to something that makes a little more sense to humans. This can help you finding and selecting objects in larger scenes. You can change a name by clicking on the standard name in the channelbox. When you have already used a name, e.g: door and you name another object door, Maya will automatically suffix a number, making the name unique. So your new door will be named door1 and so on.

Interface channelbox2.jpg

In the Outliner you can select objects by name, so giving them a logical name can be very useful.

Creating objects using faces

Create polygon tool

With the Create Polygon Tool it's possible to create faces in any shape by clicking the corners of the desired face. You can find this tool in the polygons menuset under Mesh > Create Polygon Tool:

Createpolygontool01.jpg

Your pointer will turn into a cross and you can now start clicking the corners of the desired face. When not using snap options the points will be placed flat in the view port you're working in. If you're working in the perspective view the points will be placed flat in the y-direction. If the face is finished you press [enter] on your keyboard to close it.

If the face has the wanted shape don't click on the starting point again like when drawing with lines, this will create a double vertex there, which can cause problems later on!

If you want to create a hole in the face, you finish the shape, and before closing it with enter press control on your keyboard while clicking the first point of the shape of the hole. After that you can proceed to click the next points of the hole (without pressing control). You can start another hole by pressing control again while clicking the first point of the new hole. When your shape is finished (with or without holes) press enter to close it.

Createpolygontool03.jpg

If you press backspace on your keyboard (before you've closed the face with enter) you can go back a point. You can do this as many steps back as you'd like.
If you're drawing a face it's convenient to draw counter-clockwise, in that way the normals of the face will be facing upwards, which is easier if you want to extrude the face later. See the section in this chapter about normals for more information on normals.

After you have closed the face you can adjust it in component mode like all other polygon geometry.

For a more elaborate explanation of the create polygon tool we refer to the Modeling an orthogonal pavilion tutorial.

Normals

In Maya each surface has a front and a back side. This has consequences for how the face responds to certain commands. Which side is the front and back can be shown by the normals. You can display the normals of a face by selecting the face, then going to Display > Polygons > Face Normals:

Normals01.jpg

On one side you'll see a line perpendicular to the face. This side is the front. If you would extrude this face the arrow will point in that direction too. If you want to change front and back, select the face and go to Mesh Display > Reverse:

Normals02.jpg

The faces of a volume also have normals. The normals of primitives automatically are turned outwards.

If you have created a volume out of a face and have trouble with an operation like Booleans, check if the normals of both objects are turned outwards. If not, select the object(s) with the normals in the wrong direction and reverse them.

To hide the normals, select the object and go to Display > Polygons > Face Normals again.

Extrude

If you have a face and want to make it into a volume you can use the extrude command. First select the face you want to extrude and then go to Edit Mesh > Extrude:

Extrudeface01.jpg

Then the Manipulator Tool appears on the face. You can now pull the arrow of the direction you want to extrude the face in to make the face into a volume. You can also numerically put in the value of the extrude in the channelbox

Extrude02.jpg

Always extrude the face in the direction of the arrow, otherwise you will turn the volume inside out. If the arrow doesn't point in the direction you want it to it's better to either undo the extrude command en reversing the normals of the face first or to pull it in the direction of the arrow and moving the volume afterward.
Check that point snap is not enabled, or you may experience difficulties performing an extrude (it may keep snapping to the base of the extrude)
When you have extruded a face Maya automatically jumps to component mode. Click it back to object mode to be able to select objects again.
You may want to check that keep faces together is checked in the top of the Edit Mesh menu. You can also turn on keep faces together in the inputs of the extrude through the channelbox of the object (click the polyExtrudeFace node, scroll down to keep faces together and set it to '1' or 'on').

Creating objects using curves

It is possible to create polygons using curves. This can be convenient if you have a curved surface or when you are using lines from Autocad. The modeling with curves however is elaborately discussed in the modeling with nurbs section because when (polygonal) geometry is being created through the use of curves, it is actually curves being made into nurbs geometry being made into polygon geometry. There is also the Tutorial Modeling Villa Savoye that specifically covers modeling Polygons using curves.

Creating objects by duplicating

In Maya the way to duplicate objects is by using the menu Edit » Duplicate Special. By default it makes an exact copy of the selected objects on the exact same position. Use the move tool to change the position of the copy to make it visible.

The duplicate menu is a little more advanced than you might think at first sight. By choosing Edit » Duplicate SpecialOption Box the duplicate options dialog is shown. These options enable you to create multiple copies and, if desirable, translate, scale or rotate these separate copies. To reset these settings, you can choose Edit » Reset Settings.

Maya will duplicate using the pivot point as base point. So if you want to use the rotate options, the duplicate will be rotated around the pivot point. Keep this in mind e.g. when you want to make a winding stair around a specific point.

Duplicate Options.jpg

Duplicate Transform.jpg

Editing geometry

Pivot point

Every object in Maya has a pivot point, which can be seen as the center of gravity of that particular object. All transformations of the object, like moving, scaling and rotating, act around the pivot point. When one of the transformation tools in the toolbox is selected, the pivot point is visible as the red, green and blue axis. By default the pivot point is in the center of the object, but it can be moved to every other position. To change it's position press the ‘insert’ key on you’re keyboard to ‘unlock’ the pivot. Then click and drag the pivot to the position you want. Press the ‘insert’ key again to ‘lock’ the pivot. Now all transformation act around the new position of the pivot point.


Pivot Point.jpg


In some cases you want the pivot point back in the center of the object. Via Modify » Center Pivot the pivot point is placed in the center of the object.


Center Pivot.jpg

Component mode

Vertex

When the square icon is selected, the vertices become visible as purple dots. The vertices can be selected and the position can be altered by using the transform, rotate or scale tool. A single vertex can not be rotated or scaled, but when multiple vertices are selected, they can be rotated or scaled relative to each other.

Edge

When the icon with the blue line on a surface is selected, edges of polygonal objects can be selected and transformed. Edges can be moved, rotated and scaled. By transforming an edge, in fact the adjacent vertices are transformed.

Face

When the icon with the four squares is selected, faces can be selected and transformed. Faces become visible as blue dots on the faces of the object. Faces can be moved, rotated and scaled. By transforming a face, in fact the adjacent vertices are transformed.


Interface w.jpg

Snapping

Fitting two object exactly to each other, like for example two walls, is very tedious just by hand. For this purpose snap tools are available in Maya. Snapping makes objects kind of magnetic to each other. Since transformations act around the pivot point, snapping uses the pivot point as reference. So before snapping an object to another, it’s necessary to reposition the pivot point to the desired reference point on the object. The snap options can be found in the status line above the view ports. These can be enabled by clicking on one of them. To disable a snap option, click on it again. These three snap options are most commonly used:

  1. grid snap
  2. curve snap
  3. point snap


Snap Tools.jpg


Grid snap is pretty straight forward. The grid becomes magnetic to the pivot point of an object. Use the move tool to move the object and move your mouse cursor to a grid point to snap the object exact to the grid. The point snap works similar and makes the vertices of polygonal objects magnetic. Again use the move tool to move an object and move your mouse cursor to a vertex or corner point of the object to snap to. The curve snap works a little different. Select the object that you want to snap. Make sure that the move tool is selected. Now go to the object you want to snap to. Hover your mouse cursor over a curve or edge and click and drag with your middle mouse button, i.e. the scroll wheel, over that particular curve or edge. The object will jump to that curve or edge. Release your middle mouse button at the desired location.


Snapping Example.jpg


When you move an object to snap it to another, you can choose to move it in all directions by click and dragging the manipulator in the center of the axis. The object is free to snap in all directions. It is also possible to constrain the snap direction to one particular axis. This so called constraint snapping is done by clicking and dragging just one of the axis of the manipulator and moving the mouse cursor to the desired point to snap to.


Constraint Snapping Example.jpg

Split Polygon Tool/Interactive Split Tool/Multi-Cut Tool

If you want to split a face into more faces you can use the split polygon tool. With this tool extra vertices and edges are added. The exact name and location of this tool depend on the Maya version:

Maya 2011 and before
Edit Mesh » Split Polygon Tool
Maya 2012-2014
Edit Mesh » Interactive Split Tool
Maya 2015-2016
Mesh tools » Multi-Cut Tool

Click on the option box next to it. This will make the settings of the Split Polygon tool appear at the spot of your channel box:


Multi-Cut Tool (Maya 2015 and later):

Maya Multi-Cut-Tool Options.png

Make sure the Multi-Cut Tool is selected in the Mesh Editing Tools section of the Modeling Toolkit window and use the Snap Step % setting to specify at what percentage increment to snap on an edge. Use Shift to enable snap mode.


Interactive Split Tool (before Maya 2015): Splitpolygontool.jpg

The divisions shown in the settings are the number of divisions the new inserted edge will have. With the smoothing angle you can control how hard or soft the edges of your split geometry will be; use a low value (0) to let the edges appear hard. It can be really convenient to use snapping points along the edges. The number of points is the number of points per edge your mouse will snap to. These points are evenly divided along the edge. The snapping tolerance will determines how close the vertex needs to be to the snapping point before it snaps to it.

Now you can click and drag your mouse along an edge of the face you want to split:

Splitpolygontool02.jpg

Now you can adjust the object further by going into component mode and moving the vertices or edges.

Merge vertices

It is possible to merge multiple vertices into one. Select the vertices you want to merge in component mode, then go to the option box next to edit mesh > merge vertices. The settings of the merge vertices command will be shown:

Mergevertices01.jpg

The threshold is the amount of units within which the selected vertices should be for Maya to merge them and is automatically set to 0,0100. If the vertices you want to merge are further apart, put in a number that is bigger than the amount of units the vertices are apart from each other, after that press merge:

Mergevertices02.jpg

The merge vertices command can also be a solution to problems with a Boolean operation. If for instance both objects disappear when using Booleans > difference, one of the possible reasons could be that one or both of the objects have 2 vertices on the same spot. To solve this, select both objects and use the merge vertices command (for this the threshold needs to be very low, for instance 0,01, because you only want to merge the vertices that are on the same place, so check this in the option box).

Booleans

Boolean operations can be performed on 2 overlapping polygon objects. Select both objects and go to Mesh > Booleans >

Booleans01.jpg

There are 3 options:

union
you keep the part of the objects that is part of one or both of the objects
difference
you keep the part of the object first selected that doesn't overlap with the object that has been selected second
intersection
you keep the part of both objects that overlaps

Booleans02.jpg

When you're using the union or the intersect option it doesn't matter in which order you select the objects. For the difference option, the second object you select will be subtracted from the first object you select.


When you're using the difference option it's possible you want to make a lot of holes in the object, like in the example below. It will be rather time-consuming to do them all one at a time and sometimes the geometry does odd things when doing it that way. So if you want to subtract these shapes all in once, you have to combine them first (select all the objects you want to subtract, then go to: mesh > combine). Now select the object you want to subtract from, then select the combined objects you want to subtract, then go to Mesh > Booleans > difference:

Booleans03.jpg


Relative transform

You can transform your object relative to it's current place, scale or rotation with an exact number of units. To do this, go to the little triangle next to the input field at the right top of your screen. when this field is not visible it could be hidden (click the small bars to open it). Click on the triangle and choose relative transform:

Relativetransform01.jpg

Now select the tool corresponding to the transformation you want to do (eg. if you want to move the object from it's current location select the move tool) because that's the kind of transformation Maya will do and select the object you want to use it on. Now you can enter the amount of units you want to move, rotate or scale your object in the X, Y and Z fields shown above. You can either do it in only one direction or 2 or 3 directions at the same time. Press enter to execute the transformation.

Note that Maya always uses points as a decimal separator, not a comma.

You can use the relative transform for objects, but also for components or groups.

Relativetransform02.jpg

Distance tool

Sometimes you need to know the exact distance or size of something, it can be convenient to use the distance tool for that. The distance tool can be found under Create > Measure tools > Distance tool. The distance tool measures the distance between the two points you specify by clicking in your view port. Using point snap can be really useful when doing this. If you move one of the pointers afterward with the move tool the distance is updated automatically.

Ditancetool01.jpg


Troubleshooting

The page Modeling with polygons: Troubleshooting covers troubleshooting polygon modeling.

Tutorials

Modeling an orthogonal pavillion in 7 steps. Category: easy

The tutorial Modeling an orthogonal pavillion consists of the chapters:

Modeling Villa Savoye by le Corbusier using curves. Category: medium

The tutorial Modeling Villa Savoye consists of the chapters:

Modeling Walker residence by Frank Lloyd Wright. Category: difficult

The tutorial Modeling Walker residence consists of the chapters:





Overview of Maya topics

Maya main index

Personal tools
Actions
Navigation
Tools