Quick start with Maya

From TOI-Pedia


Why using 3D digital data in the design process?

Highly accurate 3D digital model

Technical drawings are the main form of communication of the design in the design process, at least: they used to be and nowadays still are in most fields. These are 2D representations of objects that are 3-dimensional, which means these drawings are limited in what they can show and hard to interpret by the general public. There is also the risk that the 2D drawings are inaccurate or incorrect, which can cause major problems during the construction phase or when a project has been delivered. Capturing the design in 3D can avoid a major part of these problems

Besides communication, the most common application of the 3D architectural model is visualization of the design. Visualizations can be used for acquisition, but also as a tool for simulating architectural design decisions (e.g: the choice of a cladding material).

3D digital models can also be used as a basis for simulation and analysis. This can be extended to the manufacturing process: digital manufacturing of building components or rapid prototyping of design solutions.

Interior Render, S. Mulders

Maya is used at the Faculty of Architecture of the TU Delft for a number of reasons. The list below is a brief overview of some of the key reasons; it's by no means the complete account:

  • Maya combines several modeling options: Polygons, NURBS and Sub-D's making it very flexible
  • Maya support history-based modeling, allowing parametric design methods
  • Maya's extensive animation and dynamics supports allows advanced conceptual architectural design approaches
  • Maya's open architecture allow the program to be extended using MEL and Python scripting and C++ programming

So what is Maya?

Simply put, it's a computer program that enables you to create advanced virtual 3d models.

But to be more precise, Maya software is an open and integrated 3D modeling, animation, effects and rendering application.

Maya can be used to:

How to use Maya in the architectural process

XXL: A.van Hees, J.Breider, B.Meijerman, E.den Hartog, C.Leung, M.Flint, S.Mulders

The answer to this question really depends on your project and personal preference. This chapter gives a brief overview of the most important applications in the architectural process.

Mass study
Maya can be used as a 3 dimensional sketch tool, generating volumes for a Mass Study.
Conceptual design
research design decisions regarding the shape and geometry of the design, but also properties such as materials and lighting. The end result can be communicated through visualizations rendered from the 3D model in Maya.
Preliminary design
Maya can be used to communicate the design between the actors in the design process (the specialists), but also to other stakeholders. Furthermore the 3D model can be used by specialists to do simulations and analysis of the design.
Final design
Depending on the accuracy of the 3D model it can be used for a variety of applications, such as visualizations, manufacturing of building elements and components. 3D models can even be used as the legal document describing the design.

Maya Help

When you start working with a program as versatile as Maya, your bound to run in to some problems. Don't let this deter you, because there are plenty of possibility’s to find an answer to those problems.

One of those possibility’s is the Maya help, Maya has an excellent and extensive help system that can be accessed by pressing [F1] key on the keyboard:

Maya help.png

The general help screen opens from where you can look up your specific problem, either by browsing through the help files:

Maya help contents.png

or by searching:

Maya help search.png

But the quickest method usually is selecting the help file directly from the window where you've ran into a problem:

Maya help duplicate.jpg

This opens up the correct help file:

Maya help duplicate open.png


The TOI-Pedia is an ever growing database with loads of useful information and tutorials. You can find solutions to most common problems with Maya, AutoCAD, Photoshop, Illustrator, Dreamweaver and Premiere.

Because all the information on the TOI-pedia is cross referenced, there are multiple ways to reach a certain piece of information. You can navigate by:

  • Subject: find information related to a certain topic
  • Software: find all information for a specific application
  • Course: find information that is relevant for a specific course
  • Search: find practical information by entering one or more keywords

Toipedia general.jpg

You could also use the Search bar to find a specific piece of information.

Running Maya

Maya should be installed on all computers at the faculty of Architecture, including the TU Delft Student Laptops. The software has been made available to students to install on their own computer as well. You can find out more on how to get your copy of Maya as a student of the faculty of Architecture on the Maya for Students web page.

When you're running Maya on your laptop or computer at home, you have to make sure you're connected to the TU Delft Campus network to be able to use the TU Delft license for Maya. When you're connected to the wired or wireless network of the TU Delft, you should be OK. When you're working at home using your own internet connection, you probably need to use VPN to connect to the TU Delft network. More information can be found on the Maya for Students web page mentioned above.

Maya Interface

Every program has an interface to communicate with the user. The layout of an interface has a certain logic to it, so the user can easily find a function without having to know all the positions of the different functions by heart. So if you know how an interface works you will find everything a lot faster.

Mostly you will work from left to right, from top to bottom; the commands you will use first (like opening a file) are placed in the upper left corner, and information about created objects can be found on the right.


The layout of the menu bar is the same as the overall interface; frequently used commands are placed on the left. Because Maya has many menus for various tasks, the menu bar has been split into a fixed part (File, Edit, Create, Select, Modify, Display, Windows,[...] ,Cache, Help) and a part that can be set to a specific task using a Pull-down menu. This pull-down is located on the left side, directly beneath the File and Edit menus:

Maya Interface pulldown.png

When you change the pull-down menu from Modeling to Animation, the menus after 'Windows' are changed to the menus specific for animation:

Maya interface animation.png

And below when set back to Modeling:

Maya Interface modeling.png

Let's take a closer look at the 'Modeling' set menu bar. It starts with four items for polygonal mesh objects: Mesh, Edit Mesh, Mesh Tools, Mesh Display. Mesh contains commands for changing polygon objects. The next two menus are Edit Mesh and Mesh tools: functions to add/remove polygon objects and/or components to polygone meshes. Mesh Display contains helpful display functions for polygonal objects/components.

Menus Curves and Surfaces contain commands related to NURBS curves and surfaces.

It's impossible to know every command by heart. But when you see the logic of the way all commands are structured in the menus, it shouldn't take too long to find what you're looking for.


On the left side next to the viewport you find the toolbox. Here you can find the selection tool and the Transformation tools you can use to move, rotate or scale objects. The Show Manipulator Tool offers a more advanced manipulator that allows multiple transformations simultaneously and is geared towards custom operations on specific objects.

Below these tools you find the viewport tools; one perspective viewport, 1 perspective and 3 orthogonal viewports, and viewport with outliner. In the outliner you can find a list of objects in your scene.

Maya Interface toolbox.png


Below the Menu bar we find the Status Line. Various functions are located here: first the file buttons, then the selection options and masks, snap buttons, rendering buttons, the input box and finally the sidebar buttons.

Maya interface statusline.png


By default the workspace shows one single panel with a default view of your scene (with standard grid). This panel shows your scene as viewed from the standard perspective camera (persp). When you navigate through your scene the camera you look through is actually moved.

Interface 0.jpg

You can use the Quick Layout Buttons (below the Tool Box) to change to the Four View. This will replace the single panel with 4 panels: 3 orthogonal views ( front, side and top) and one perspective (persp).

Interface 3viewports.jpg

You can quickly switch from the Four View to a Single View by tapping your space bar while hovering your mouse over the panel you want to enlarge. When you tap space again, you will switch back.

You can change the camera that is shown in each of the views by using the pull-down menu Panels in the panel. Here you can switch between the different cameras. You can find the cameras in either the Perspecitive or Ortographics sub-menus, depending on the type of camera.

Maya Viewport panelsmenu.png


To navigate in 2D and 3D space you have to use Alt in combination with the mouse buttons.

Alt + left mouse button: rotate (tumble)
Alt + middle mouse button: pan (track)
Alt + right mouse button: move closer or farther (dolly)

Using Alt + Ctrl + left mouse button will allow you to draw a box to move closer or farther (dolly). In most cases you can also use the scroll wheel on your mouse to dolly in or out, although it may be less smooth and precise.

When you are moving around keep an eye on your coordinate system: the y-axis should point up.

Interface navigate.jpg


The Channelbox is on the right side of the screen. In this menu you will find all the properties of the selected object, and you can change those properties. If you apply a certain operation on an object, Maya will remember this. This is called the construction history of an object and that is also shown here.

Interface channelbox.jpg

If you create an object in Maya it will automatically get a unique name. When you are building a large building or model it can be useful to change the standard name of an object to something that makes a little more sense to humans. This can help you finding and selecting objects in larger scenes. You can change a name by clicking on the standard name in the channelbox. When you have already used a name, e.g: door and you name another object door, Maya will automatically suffix a number, making the name unique. So your new door will be named door1 and so on.

Interface channelbox2.jpg

In the Outliner you can select objects by name, so giving them a logical name can be very useful.

Script Editor

Maya is a very broad software application with numerous possibilities and applications. Nevertheless it's flexibility is one of the key features: there are several options to tailor the program to your own needs and demands and to add new functionality yourself. One of the key components to do that is the Maya scripting language, MEL. MEL stands for Maya Embedded Language. In fact the entire interface of Maya as you know it is written in MEL. Everything you do and see in the interface corresponds with one or more MEL commands.

Below the ChannelBox you see a white line and a gray line. On the right to the gray line there is one button, here you find the script editor (also; you can open the Script Editor through Windows » General Editors » Script Editor. This interface is used to enter commands and scripts, but the history panel also provides feedback. On the left the chosen script language can be changed. If you want to execute a MEL script, make sure it says MEL on the left.

Maya Interface scripteditor.png

If the Script Editor is opened, you'll see a window similar to the image below. The window is divided in two parts: The top part is the history, the bottom part is where you can type. Here you can also choose between scripting in MEL or in Python. The history probably already contains some output. You'll notice that most actions in Maya result in output in the history panel. It shows the commands that are being executed and the results of those commands. In this image you can see part of the commands used to make the objects.

Interface scripteditor002.jpg

Display options

Maya has different options for displaying the objects. When you start Maya will show objects as green lines (when selected) and blue lines, when not selected, the so called wireframe mode. You can also get to this mode pressing 4 on your keyboard. If you want to see shaded objects you press 5. (See below)

Interface displayoptions.jpg

Other display options you can get by pressing 6 and 7. 6 will show you textures and 7 will show the light setup and possible shadows.

If you press 8 the Paint Effects panel will become active. By pressing 8 again you will go back to the normal view. You can go back to a 'normal' tool by selecting the Select, Move or any other tool from the Tool Box.
If you press 2 or 3 when one or more polygon objects are selected, Maya will change the display for these objects to smooth display. Press 1 to go back to the default display.


Different types of Geometry

Maya uses three different types of geometry. Every type has it’s own purpose. The three types are: Polygons, NURBS and Subdivision surfaces, often called subdivs. Each of them requires a different method of editing. Therefore a basic understanding of each geometry type is necessary when you start modeling.


A polygon is a surface that consists of three points called vertices. The three vertices together form a triangular surface called a face. The edges of this face are straight lines connecting the vertices, so a face is always a flat surface. A polygonal object is constructed out of these faces. In Maya a face can consist of more than three vertices. This is for easy editing purposes, but in fact the faces are always subdivided in triangular faces.


Modeling with polygons is a fast and easy way of modeling. Editing a polygonal object is basically moving vertices of faces the object is build off. Therefore polygon geometry is suitable for most common modeling tasks. The downside of polygons rises in the fact that faces are always flat. In cases of curved surfaces, polygon geometry is always an approximation of the curved surface. By adding more subdivisions, i.e. more and smaller faces, it is possible to create a better approximation. This however results in more data and a 'heavier' model.

Poly Subdivisions.jpg


NURBS is an abbreviation of non-uniform rational B-spline. NURBS geometry is created by two or more curves defining the surface in between. The way those curves are generated, makes NURBS geometry very flexible. A curve consists of a start point, an end point and several control vertices in between, defining the tangent of the curve. Depending on the 'degree' of the curve, defining the amount of control points, a curve can be linear, with straight angles, or curved. NURBS surfaces consist of the aforementioned control vertices (CVs), defining the tangent of the surface, and curves lying on the surface, called isoparms. Those isoparms are the curves the surface is build from.

NURBS Geometry.jpg

NURBS geometry allows you to create surfaces curved in multiple directions. This geometry type is very useful for more complex and curved objects. The amount of flexibility is very high. Calculating NURBS curves and surfaces however, is a lot more demanding than polygon geometry. The choice of geometry type for a certain modeling task depends on the demand of flexibility, modeling speed and precision.

Subdivision surfaces

Subdiv geometry is a sort of a combination of NURBS and polygon geometry. In search of a geometry type with the flexibility of NURBS and the easy editing of polygons, subdivs were developed. Subdiv geometry will not be discussed in our courses, so for more information on subdivs we direct you to Subdivision Surface on Wikipedia or other sources.

Creating Geometry with Primitives

There are several methods of creating geometry in Maya. The easiest way is to start modeling with primitive forms like a cube or a sphere. Maya has several primitives available. In the pull-down menu ‘Create’ the first three options enables you to choose the type of geometry.

For example you can choose Create » NURBS Primitives » Sphere to add a NURBS sphere to our scene. Clicking on the square behind each menu item called option box, enables you to set initial settings of the primitive.


Maya Create Primitives.png

Selection Tools

There are a couple of ways of selecting objects in Maya. If you are still in another tool, make sure that the selection tool in the toolbox is selected or press Q on your keyboard. Select an object by clicking on it. By holding the Shift key it’s possible to select multiple objects. Clicking and dragging a window around the objects is a faster way of selecting multiple objects. With the lasso tool in the toolbox you can drag a non-rectangular selection around the objects. To remove objects from the selection hold the Control' key while clicking the objects.

Selection Tools.jpg

Pivot Point

Every object in Maya has a pivot point, which can be seen as the center of gravity of that particular object. All transformations of the object, like moving, scaling and rotating, act around the pivot point. When one of the transformation tools in the toolbox is selected, the pivot point is visible as the red, green and blue axis. By default the pivot point is in the center of the object, but it can be moved to every other position. To change it's position press the ‘insert’ key on you’re keyboard to ‘unlock’ the pivot. Then click and drag the pivot to the position you want. Press the ‘insert’ key again to ‘lock’ the pivot. Now all transformation act around the new position of the pivot point.

Pivot Point.jpg

In some cases you want the pivot point back in the center of the object. Via Modify » Center Pivot the pivot point is placed in the center of the object.

Center Pivot.jpg

Transforming Objects

When an object is selected, it can be transformed. To move, rotate or scale, select the particular tool in the toolbox. Click and drag the manipulator on the colored axis of choice to perform the desired transformation. When selecting one axis, the transformation is only performed on that particular axis. For transforming in all directions click the yellow icon in the center of the manipulator

Transformation Tools.jpg

For example, if we want our object to scale in the z-axis, we select the object, we then select the scale tool in the toolbox, the manipulator is shown and we click and drag the blue cube to scale the object.

The transformations are numerically shown in the ‘Channel Box’ on the right. You can input the transformation values manually here. So the use of exact measures is possible this way instead of dragging the manipulator a random amount. For mirroring objects it is possible to input a negative scale value in the channel box.


Snap Tools

Fitting two object exactly to each other, like for example two walls, is very tedious just by hand. For this purpose snap tools are available in Maya. Snapping makes objects kind of magnetic to each other. Since transformations act around the pivot point, snapping uses the pivot point as reference. So before snapping an object to another, it’s necessary to reposition the pivot point to the desired reference point on the object. The snap options can be found in the status line above the view ports. These can be enabled by clicking on one of them. To disable a snap option, click on it again. These three snap options are most commonly used:

  1. grid snap
  2. curve snap
  3. point snap

Snap Tools.jpg

Grid snap is pretty straight forward. The grid becomes magnetic to the pivot point of an object. Use the move tool to move the object and move your mouse cursor to a grid point to snap the object exact to the grid. The point snap works similar and makes the vertices of polygonal objects magnetic. Again use the move tool to move an object and move your mouse cursor to a vertex or corner point of the object to snap to. The curve snap works a little different. Select the object that you want to snap. Make sure that the move tool is selected. Now go to the object you want to snap to. Hover your mouse cursor over a curve or edge and click and drag with your middle mouse button, i.e. the scroll wheel, over that particular curve or edge. The object will jump to that curve or edge. Release your middle mouse button at the desired location.

Snapping Example.jpg

When you move an object to snap it to another, you can choose to move it in all directions by click and dragging the manipulator in the center of the axis. The object is free to snap in all directions. It is also possible to constrain the snap direction to one particular axis. This so called constraint snapping is done by clicking and dragging just one of the axis of the manipulator and moving the mouse cursor to the desired point to snap to.

Constraint Snapping Example.jpg

Editing on component level

As described in the section of geometry types, geometry consists of different components that it’s build from. It is possible to transform objects by transforming these components. This is a very common way of editing your objects during modeling. In the status line you can switch between component and object mode. When the component mode is selected a couple of options become available. With these options it’s possible to address a certain component type.

Maya2016 Component Mode.png

Depending on the geometry type, those components can differ, so both polygon and NURBS geometry is discussed separately.

Polygon components


When the square icon is selected, the vertices become visible as purple dots. The vertices can be selected and the position can be altered by using the transform, rotate or scale tool. A single vertex can not be rotated or scaled, but when multiple vertices are selected, they can be rotated or scaled relative to each other.


When the icon with the blue line on a surface is selected, edges of polygonal objects can be selected and transformed. Edges can be moved, rotated and scaled. By transforming an edge, in fact the adjacent vertices are transformed.


When the icon with the four squares is selected, faces can be selected and transformed. Faces become visible as blue dots on the faces of the object. Faces can be moved, rotated and scaled. By transforming a face, in fact the adjacent vertices are transformed.

Interface w.jpg

NURBS components

Control Vertex

For a NURBS object the square icon in component mode enables you to transform the control vertices. Control vertices define the tangent of the surface. In contrast to vertices of polygonal objects the control vertices of NURBS objects don’t lie on the surface by definition. The control vertices can be selected and the position can be altered by using the transform, rotate or scale tool. A single control vertex can not be rotated or scaled, but when multiple control vertices are selected, they can be rotated or scaled relative to each other.

Edit Point

With the round icon selected, edit points become selectable. Edit points can be used in several tools for editing NURBS objects. Edit points of NURBS surfaces cannot be moved, rotated or scaled. Edit points of curves on the contrary can be transformed.


With the icon with the blue line selected, isoparms can be selected. Isoparms can be used, like edit points, in several tools for editing NURBS objects. By dragging an isoparm over the geometry surface isoparms can be moved. Isoparms cannot be transformed by the move, rotate and scale tool.

Maya2016 Component Mode NURBS.png

Duplicate options

In Maya the way to duplicate objects is by using the menu Edit » Duplicate Special. By default it makes an exact copy of the selected objects on the exact same position. Use the move tool to change the position of the copy to make it visible.

The duplicate menu is a little more advanced than you might think at first sight. By choosing Edit » Duplicate SpecialOption Box the duplicate options dialog is shown. These options enable you to create multiple copies and, if desirable, translate, scale or rotate these separate copies. To reset these settings, you can choose Edit » Reset Settings.

Maya will duplicate using the pivot point as base point. So if you want to use the rotate options, the duplicate will be rotated around the pivot point. Keep this in mind e.g. when you want to make a winding stair around a specific point.

Duplicate Options.jpg

Duplicate Transform.jpg

Managing a 3d model


As with any computer program, it's important to keep your work organized. This is especially true when working with complicated scenes that include texture files. A texture file is usually a .JPEG image of a material (for instance a brick wall). It's important to keep all these separate files together otherwise Maya won't be able to find them. There for you need to set your project

A Maya project can consist of many files in various categories. To keep all this data structured, Maya uses a defined project structure. It is important to use a Project to make sure all relevant data can always be located. You may run into trouble, especially with file textures when you don't use this structure or when you forget to Set your project.

Some typical locations for different types of files within your project

Maya scene files (.mb) are stored in the scenes/ directory.
all pictures used as file textures are stored here.
all rendered images data are store by Maya are saved here.

Starting a new Project

  1. Go to File » Project Window
  2. Click New
  3. Enter a name (Current Project field)
  4. Choose a location by clicking on the folder icon.
  5. Click Accept

Continuing an existing Project

Every time you start Maya, the first step is to tell Maya which project you're working on:

  1. Go to File » Set Project
  2. Choose the folder in which your Maya project reside. This would be the directory with your project name that is created by Maya when you start a new project.
When you've worked on a project before on a specific computer, you can select it from the Recent Projects list in the File menu

File Management

Now that we know how to set a project it's time to look at some basic rules of file management. By following these rules you'll be sure that you keep your work organized and efficient.

Beginning a project

First, set your project. (by setting a project Maya knows the location where all files of your project should be saved and files will automatically be placed (and found) in a proper location)

Don't use spaces in file names (spaces aren't always supported properly, for example when using batch rendering).

Always use comprehensible file names:




The description should point out whether a file is relevant for the current project. De description 'construction' helps other people that work on the project to identify the contents of a specific file. By including the authors name, everyone knows who to address when there's a problem. The date shows when a file was last modified and whether or not a file contains information that is up to date. Adding a version number refines this, so different versions can be saved for a specific date.

When file referencing is used, it's more convenient to strip the date and version number. Nevertheless it's recommended to use a date and version number for archived files. The file that should be used for referencing could be named filename_current.mb.

File textures

Use clear names for file textures.


Textures: filetype and resolution

Save textures as JPG (non progressive!) using maximum quality (minimum compression).

The resolution depends on the desired quality and the size of the texture in the final render. Use very large textures with caution: it can negatively affect the render speed. Use resolutions between 640-480 and max. 1600-1200. Higher resolutions should only be used exceptionally.

Store textures in the sourceimages directory of the Maya project, so NOT in the textures directory!


Now we've covered the basics, you may want to practice a bit. You can start with one of the Polygon Modeling tutorials

Personal tools